summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 3 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 85bdf71..98961eb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,7 +4,7 @@ CFLAGS=-O2 -Wall -g
INSTALL_PROGRAM=install
%:
- dh $@
+ dh $@ --with autotools_dev
override_dh_auto_configure:
./configure $(GPMCONFIG) --prefix=/usr --sysconfdir=/etc \
@@ -14,11 +14,9 @@ override_dh_auto_test:
# make test is interactive; skip it
override_dh_auto_clean:
+ dh_autotools-dev_updateconfig
if [ -e Makefile ]; then $(MAKE) distclean; fi
- -test -r /usr/share/misc/config.sub && \
- cp -f /usr/share/misc/config.sub autoconf/config.sub
- -test -r /usr/share/misc/config.guess && \
- cp -f /usr/share/misc/config.guess autoconf/config.guess
+ dh_autotools-dev_restoreconfig
override_dh_auto_install:
$(MAKE) INSTALL_PREFIX=debian/pdmenu \