summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJames R. Barlow <james@purplerock.ca>2021-07-18 00:32:56 -0700
committerJames R. Barlow <james@purplerock.ca>2021-07-18 00:32:56 -0700
commit9b85a74d119992ad29bca46385b9b461b830f4d5 (patch)
tree20ebdfc8cd0ec3ee4378608b49c3c81d40adcd9a /Makefile
parent096d6b26c8827de207c128d5d973ad756c2cfd70 (diff)
makefile: reintroduce a way to rebuild C++ ext
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 8239ae0..5ce2420 100644
--- a/Makefile
+++ b/Makefile
@@ -7,6 +7,10 @@ all: build
invalidate-cppcov:
find . -name "*.gcno" -delete
+.PHONY: ext
+ext: invalidate-cppcov
+ python setup.py build_ext --inplace
+
.PHONY: build
build: invalidate-cppcov
# python setup.py build_ext --inplace