summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJames R. Barlow <james@purplerock.ca>2021-07-06 23:41:50 -0700
committerJames R. Barlow <james@purplerock.ca>2021-07-06 23:41:50 -0700
commitb974c3bb0582ae9df9ba79c3b7d0798060a0d3fd (patch)
treeca15d389fdb8e380e9989a305517164ac1669a62 /Makefile
parentc1a588cb0e197a5e83845163ebf68dbf537448fc (diff)
Add Apple wheel instructions to Makefile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index c2a3463..8239ae0 100644
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,8 @@ invalidate-cppcov:
.PHONY: build
build: invalidate-cppcov
- python setup.py build_ext --inplace
+ # python setup.py build_ext --inplace
+ python -m pip install -e .
.PHONY: clean-coverage-pycov
clean-coverage-pycov:
@@ -33,6 +34,23 @@ clean: clean-coverage
test: build
pytest -n auto
+version := $(subst v,,$(shell git describe --tags))
+macwheel := pikepdf-$(version)-cp39-cp39-macosx_11_0_arm64.whl
+#$(info $$version is [${version}])
+#$(info $$macwheel is [${macwheel}])
+
+$(macwheel): clean build
+ rm pikepdf*.whl
+ python -m pip wheel .
+ mv pikepdf*.whl $(macwheel)
+
+fixed/$(macwheel): $(macwheel)
+ delocate-wheel -w fixed -v $(macwheel)
+
+.PHONY: apple-silicon-wheels
+apple-silicon-wheels: fixed/$(macwheel)
+ twine upload fixed/$(macwheel)
+
.PHONY: pycov
pycov: clean-coverage-pycov
pytest --cov-report html --cov=src -n auto