summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2019-01-26 12:48:01 -0700
committerSean Whitton <spwhitton@spwhitton.name>2019-01-26 12:48:01 -0700
commit45ad094e5a7f88d200abd984b63d7c6c13d8e30a (patch)
tree041db2daa34a71a2b5346771390bb3b6d7274756 /debian/patches
parenta57c913b35d02cc223f1c9550d2ca15888bae246 (diff)
refresh patches
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/disable-test_docinfo_problems.patch11
-rw-r--r--debian/patches/docs-build-use-DEB_VERSION_UPSTREAM.patch6
-rw-r--r--debian/patches/drop-setuptools_scm_git_archive-from-setup.py.patch4
3 files changed, 10 insertions, 11 deletions
diff --git a/debian/patches/disable-test_docinfo_problems.patch b/debian/patches/disable-test_docinfo_problems.patch
index 8622872..88ab912 100644
--- a/debian/patches/disable-test_docinfo_problems.patch
+++ b/debian/patches/disable-test_docinfo_problems.patch
@@ -7,11 +7,9 @@ Needs a test resource whose DFSG status is in doubt.
tests/test_metadata.py | 17 -----------------
1 file changed, 17 deletions(-)
-diff --git a/tests/test_metadata.py b/tests/test_metadata.py
-index 35eff81..8d4fae5 100644
--- a/tests/test_metadata.py
+++ b/tests/test_metadata.py
-@@ -48,12 +48,6 @@ def trivial(resources):
+@@ -50,12 +50,6 @@ def trivial(resources):
@pytest.fixture
@@ -24,7 +22,7 @@ index 35eff81..8d4fae5 100644
def invalid_creationdate(resources):
# Has nuls in docinfo, old PDF
return Pdf.open(resources / 'invalid_creationdate.pdf')
-@@ -290,14 +284,3 @@ def test_remove_attribute_metadata(sandwich):
+@@ -320,19 +314,3 @@ def test_remove_attribute_metadata(sandw
# Ensure the whole node was deleted
assert not re.search(r'rdf:Description xmlns:[^\s]+ rdf:about=""/', str(xmp))
@@ -39,3 +37,8 @@ index 35eff81..8d4fae5 100644
- assert 'could not be copied' in warned[0].message.args[0]
- with pytest.raises(ValueError):
- meta.load_from_docinfo(invalid_creationdate.docinfo, raise_failure=True)
+-
+- with pytest.warns(UserWarning) as warned:
+- with meta as xmp:
+- xmp['xmp:CreateDate'] = 'invalid date'
+- assert 'could not be updated' in warned[0].message.args[0]
diff --git a/debian/patches/docs-build-use-DEB_VERSION_UPSTREAM.patch b/debian/patches/docs-build-use-DEB_VERSION_UPSTREAM.patch
index b390c3b..e440dca 100644
--- a/debian/patches/docs-build-use-DEB_VERSION_UPSTREAM.patch
+++ b/debian/patches/docs-build-use-DEB_VERSION_UPSTREAM.patch
@@ -6,11 +6,9 @@ Subject: docs build use DEB_VERSION_UPSTREAM
docs/conf.py | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
-diff --git a/docs/conf.py b/docs/conf.py
-index c90d478..7e1d8bb 100644
--- a/docs/conf.py
+++ b/docs/conf.py
-@@ -43,8 +43,6 @@ else:
+@@ -52,8 +52,6 @@ else:
# documentation root, use os.path.abspath to make it absolute, like shown here.
sys.path.insert(0, os.path.join(os.path.abspath('.'), '..'))
@@ -19,7 +17,7 @@ index c90d478..7e1d8bb 100644
# -- General configuration ------------------------------------------------
# If your documentation needs a minimal Sphinx version, state it here.
-@@ -92,7 +90,7 @@ author = u'James R. Barlow'
+@@ -101,7 +99,7 @@ author = u'James R. Barlow'
# |version| and |release|, also used in various other places throughout the
# built documents.
diff --git a/debian/patches/drop-setuptools_scm_git_archive-from-setup.py.patch b/debian/patches/drop-setuptools_scm_git_archive-from-setup.py.patch
index ba036da..9349e43 100644
--- a/debian/patches/drop-setuptools_scm_git_archive-from-setup.py.patch
+++ b/debian/patches/drop-setuptools_scm_git_archive-from-setup.py.patch
@@ -7,11 +7,9 @@ Pending resolution of #910742.
setup.py | 1 -
1 file changed, 1 deletion(-)
-diff --git a/setup.py b/setup.py
-index da65ab4..2c62fdc 100644
--- a/setup.py
+++ b/setup.py
-@@ -132,7 +132,6 @@ setup(
+@@ -134,7 +134,6 @@ setup(
setup_requires=[
'pytest-runner',
'setuptools_scm',