summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorJames R. Barlow <jim@purplerock.ca>2017-09-08 16:22:39 -0700
committerJames R. Barlow <jim@purplerock.ca>2017-09-08 16:22:39 -0700
commit886d465c79b27d0e117a69a6de602bf57eb52724 (patch)
tree55b4f5b7490ec1daac371c788ea0ca927ae3e139 /docs
parente7d9e86e1d82ba92d3c7257cc8b57acbee3a9ac1 (diff)
Documentation improvements
Diffstat (limited to 'docs')
-rw-r--r--docs/Makefile3
-rw-r--r--docs/conf.py6
-rw-r--r--docs/index.rst4
-rw-r--r--docs/pikepdf.rst12
4 files changed, 21 insertions, 4 deletions
diff --git a/docs/Makefile b/docs/Makefile
index 4c1a0fe..e47f80c 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -214,3 +214,6 @@ pseudoxml:
$(SPHINXBUILD) -b pseudoxml $(ALLSPHINXOPTS) $(BUILDDIR)/pseudoxml
@echo
@echo "Build finished. The pseudo-XML files are in $(BUILDDIR)/pseudoxml."
+
+livehtml:
+ sphinx-autobuild -b html $(ALLSPHINXOPTS) $(BUILDDIR)/html
diff --git a/docs/conf.py b/docs/conf.py
index 3be1f75..d3e4bc6 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -18,7 +18,9 @@ import os
# If extensions (or modules to document with autodoc) are in another directory,
# add these directories to sys.path here. If the directory is relative to the
# documentation root, use os.path.abspath to make it absolute, like shown here.
-#sys.path.insert(0, os.path.abspath('.'))
+sys.path.insert(0, os.path.join(os.path.abspath('.'), '..'))
+
+import pikepdf
# -- General configuration ------------------------------------------------
@@ -206,7 +208,7 @@ html_static_path = ['_static']
#html_search_scorer = 'scorer.js'
# Output file base name for HTML help builder.
-htmlhelp_basename = 'python_exampledoc'
+htmlhelp_basename = 'pikepdfdoc'
# -- Options for LaTeX output ---------------------------------------------
diff --git a/docs/index.rst b/docs/index.rst
index 998e67b..26d4ee0 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -1,4 +1,4 @@
-python_example Documentation
+pikepdf Documentation
============================
Contents:
@@ -6,5 +6,5 @@ Contents:
.. toctree::
:maxdepth: 2
- python_example
+ pikepdf
diff --git a/docs/pikepdf.rst b/docs/pikepdf.rst
index 36f33f2..d64a002 100644
--- a/docs/pikepdf.rst
+++ b/docs/pikepdf.rst
@@ -1 +1,13 @@
+pikepdf API Reference
+*********************
+
.. automodule:: pikepdf
+ :members:
+
+.. autoclass:: pikepdf.Pdf
+ :members:
+
+.. autoclass:: pikepdf.Object
+ :members:
+
+.. py:exception:: pikepdf.PdfError \ No newline at end of file