summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJames R. Barlow <jim@purplerock.ca>2019-10-19 23:38:07 -0700
committerJames R. Barlow <jim@purplerock.ca>2019-10-20 00:41:44 -0700
commit0e798a09f9cdaa8200da975f4f57b806344d8ff8 (patch)
tree45cc441bbf0aa1b2c9f8e3996967adaf8c8ed3ac /setup.py
parent663c74fa2796940e1dd0ecf27bf3c9787db3310a (diff)
Adjust build for Python 3.8
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c26840a..6fd094a 100644
--- a/setup.py
+++ b/setup.py
@@ -147,7 +147,7 @@ if __name__ == '__main__': # for mp_compile
setup_requires=[
'setuptools_scm',
'setuptools_scm_git_archive',
- 'pybind11 >= 2.3.0, < 3',
+ 'pybind11 >= 2.4.3, < 3',
],
use_scm_version=True,
tests_require=tests_require,
@@ -162,6 +162,7 @@ if __name__ == '__main__': # for mp_compile
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3 :: Only",
"Programming Language :: C++",
"Topic :: Multimedia :: Graphics",