summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJames R. Barlow <jim@purplerock.ca>2018-07-15 13:52:24 -0700
committerJames R. Barlow <jim@purplerock.ca>2018-07-15 13:52:24 -0700
commit57c6fe10ff40e124e3ccd6cc72385ccf9c01a372 (patch)
tree9347440d47a09a75504815e31ad6bc0a1028ad2e /setup.py
parent5c43c46ba7bb5a4aec98e82f51fe6c822026ebbc (diff)
Reorganize *requirements.txt and set up requirements for readthedocs
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 9 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 3e3b15e..8e056d6 100644
--- a/setup.py
+++ b/setup.py
@@ -93,7 +93,14 @@ class BuildExt(build_ext):
setup_py_cwd = dirname(__file__)
-with open(join(setup_py_cwd, 'test_requirements.txt')) as f:
+with open(join(setup_py_cwd, 'requirements/docs.txt')) as f:
+ docs_require = [
+ line.strip() for line in f
+ if line.strip() and not line.strip().startswith('#')
+ ]
+
+
+with open(join(setup_py_cwd, 'requirements/test.txt')) as f:
tests_require = [
line.strip() for line in f
if line.strip() and not line.strip().startswith('#')
@@ -112,12 +119,7 @@ setup(
ext_modules=ext_modules,
install_requires=['pybind11 >= 2.2.3, < 3'],
extras_require={
- 'docs': [
- 'sphinx >= 1.4',
- 'sphinx-rtd-theme',
- 'ipykernel',
- 'nbsphinx'
- ]
+ 'docs': docs_require
},
cmdclass={'build_ext': BuildExt},
zip_safe=False,