summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJames R. Barlow <jim@purplerock.ca>2018-05-31 01:57:58 -0700
committerJames R. Barlow <jim@purplerock.ca>2018-05-31 01:57:58 -0700
commitaca410b40a47066803a15958a6ca8a1a88dc0f33 (patch)
tree74de59f390246e0089520b6ef09f21ce75045a71 /setup.py
parent5d0b1709a3313bdae8038d3b7883635c9c08d887 (diff)
Use readthedocs.yml
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 6 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index bab59ee..890ab9a 100644
--- a/setup.py
+++ b/setup.py
@@ -103,6 +103,12 @@ setup(
long_description=open('README.rst').read(),
ext_modules=ext_modules,
install_requires=['pybind11 >= 2.2.3, < 3'],
+ extra_requires=[
+ 'docs': [
+ 'sphinx >= 1.4',
+ 'sphinx-rtd-theme',
+ ]
+ ]
cmdclass={'build_ext': BuildExt},
zip_safe=False,
python_requires='>=3.5',