summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJames R. Barlow <jim@purplerock.ca>2018-05-14 07:15:06 -0700
committerJames R. Barlow <jim@purplerock.ca>2018-05-14 07:15:06 -0700
commitba2a8501c6f0087ee4bbd86266089303cb63ca2a (patch)
tree3239ceec3afdc869017342b2892c9c613cc5d17a /setup.py
parent3380e59f1108a21acca517c1a149e2bba8757ad8 (diff)
Mark as alpha, Py3.5+
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index de8240a..bab59ee 100644
--- a/setup.py
+++ b/setup.py
@@ -105,6 +105,7 @@ setup(
install_requires=['pybind11 >= 2.2.3, < 3'],
cmdclass={'build_ext': BuildExt},
zip_safe=False,
+ python_requires='>=3.5',
setup_requires=['pytest-runner', 'setuptools_scm'],
use_scm_version=True,
tests_require=tests_require,
@@ -114,7 +115,7 @@ setup(
'': ['*.txt'],
},
classifiers=[
- "Development Status :: 2 - Pre-Alpha",
+ "Development Status :: 3 - Alpha",
"Intended Audience :: Developers",
"Intended Audience :: Information Technology",
"License :: OSI Approved :: Mozilla Public License 2.0 (MPL 2.0)",