summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJames R. Barlow <jim@purplerock.ca>2017-10-27 00:04:25 -0700
committerJames R. Barlow <jim@purplerock.ca>2017-10-27 00:04:25 -0700
commitc0c7aec9350abcb7957032affc39758dff221595 (patch)
tree7cb5f22ea5a96c3d14ad1ff8c69f978bdf7b7001 /setup.py
parent96549f0949868027a2a12d95bcf3580835510635 (diff)
Have Travis treat this as a primarily Python project
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 43f1adc..154a4db 100644
--- a/setup.py
+++ b/setup.py
@@ -88,6 +88,10 @@ class BuildExt(build_ext):
ext.extra_compile_args = opts
build_ext.build_extensions(self)
+tests_require = [line.strip() for line in
+ open('test_requirements.txt')
+ if line.strip() and not line.strip().startswith('#')]
+
setup(
name='pikepdf',
author='James R. Barlow',
@@ -101,9 +105,7 @@ setup(
zip_safe=False,
setup_requires=['pytest-runner', 'setuptools-scm'],
use_scm_version=True,
- tests_require=[
- 'pytest', 'pytest-xdist', 'pytest-timeout', 'hypothesis',
- 'Pillow'],
+ tests_require=tests_require,
package_dir={'': 'src'},
packages=setuptools.find_packages('src'),
classifiers=[