summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrej Shadura <andrew.shadura@collabora.co.uk>2019-02-20 20:00:27 +0100
committerAndrej Shadura <andrew.shadura@collabora.co.uk>2019-02-20 20:00:27 +0100
commitdb930918e24314a673f8c588cb3bba318bca95fe (patch)
tree391ba8e12167a750e0fc0b5fd4cbd49b2dd3eca4 /configure.ac
parent3e04a02fd1d845d4c72f63783fa980591a22b076 (diff)
New upstream version 1.6.0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 663e45a..9a6090a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,8 +12,8 @@ dnl implied. In no event shall the authors be liable for any damages arising
dnl from the use of this software.
AC_PREREQ([2.68])
-AC_INIT([pkgconf], [1.4.2], [http://github.com/pkgconf/pkgconf/issues])
-AC_CONFIG_SRCDIR([main.c])
+AC_INIT([pkgconf], [1.6.0], [http://github.com/pkgconf/pkgconf/issues])
+AC_CONFIG_SRCDIR([cli/main.c])
AC_CONFIG_MACRO_DIRS([m4])
AX_CHECK_COMPILE_FLAG([-Wall], [CFLAGS="$CFLAGS -Wall"])
AX_CHECK_COMPILE_FLAG([-Wextra], [CFLAGS="$CFLAGS -Wextra"])
@@ -30,6 +30,13 @@ LT_INIT
AC_SYS_LARGEFILE
+AC_ARG_WITH([personality-dir],[AC_HELP_STRING([--with-personality-dir],[specify
+ the place where cross-compile personality files will be found])],
+ PERSONALITY_PATH="$withval",
+ PERSONALITY_PATH="${datadir}/pkgconfig/personality.d:${sysconfdir}/pkgconfig/personality.d")
+
+AC_SUBST([PERSONALITY_PATH])
+
AC_ARG_WITH([pkg-config-dir],[AC_HELP_STRING([--with-pkg-config-dir],[specify
the place where pc files will be found])],PKG_DEFAULT_PATH="$withval",
PKG_DEFAULT_PATH="${libdir}/pkgconfig:${datadir}/pkgconfig")