summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 192e9bf..55246d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,8 +14,8 @@ link_directories (${CMAKE_INSTALL_PREFIX}/lib)
project (planetblupi)
set (PB_VERSION_MAJOR 1)
-set (PB_VERSION_MINOR 13)
-set (PB_VERSION_PATCH 2)
+set (PB_VERSION_MINOR 14)
+set (PB_VERSION_PATCH 0)
set (PB_VERSION_EXTRA "")
set (PB_PRODUCT_NAME "Planet Blupi")
set (PB_PACKAGE_NAME "planetblupi")
@@ -93,10 +93,13 @@ else ()
)
endif ()
file (COPY resources/image DESTINATION share/planetblupi)
-file (COPY resources/movie DESTINATION share/planetblupi)
+if (NOT BUILD_JS)
+ file (COPY resources/movie DESTINATION share/planetblupi)
+endif ()
file (COPY resources/sound DESTINATION share/planetblupi)
file (COPY resources/music DESTINATION share/planetblupi)
file (COPY LICENSE.all DESTINATION share/doc/planetblupi)
+file (COPY COPYING DESTINATION share/doc/planetblupi)
file (RENAME "${CMAKE_BINARY_DIR}/share/doc/planetblupi/LICENSE.all"
"${CMAKE_BINARY_DIR}/share/doc/planetblupi/copyright")
@@ -306,9 +309,14 @@ if (NOT BUILD_JS)
install (DIRECTORY resources/sound DESTINATION share/planetblupi)
install (DIRECTORY resources/music DESTINATION share/planetblupi)
install (FILES LICENSE.all DESTINATION share/doc/planetblupi RENAME copyright)
+ install (FILES COPYING DESTINATION share/doc/planetblupi)
if (UNIX AND NOT APPLE)
install (DIRECTORY resources/icon/hicolor DESTINATION share/icons)
+ install (
+ FILES resources/linux/${PB_PACKAGE_NAME}.appdata.xml
+ DESTINATION share/metainfo
+ )
endif ()
if (NOT USE_APPIMAGE)