summaryrefslogtreecommitdiff
path: root/configure
diff options
context:
space:
mode:
authorPaul Mackerras <paulus@samba.org>1999-09-17 05:30:57 +0000
committerPaul Mackerras <paulus@samba.org>1999-09-17 05:30:57 +0000
commit1e8f5d7e70232ca30ca317894fcacdfb8f271d24 (patch)
tree3679d7f581a6f4f1a43e0e15ec2823eaf7a6a838 /configure
parent5755b0122ae26624b5f8bab08851014ba5a4770d (diff)
fix shell if statement (bombed when lp64="")
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure b/configure
index ceaba7a..035ef6f 100755
--- a/configure
+++ b/configure
@@ -1,5 +1,5 @@
#!/bin/sh
-# $Id: configure,v 1.19 1999/09/17 04:20:10 paulus Exp $
+# $Id: configure,v 1.20 1999/09/17 05:30:57 paulus Exp $
if [ -d /NextApps ]; then
system="NeXTStep"
@@ -110,16 +110,16 @@ if [ -d "$ksrc" ]; then
rm -f Makefile
ln -s $ksrc/Makefile.top Makefile
echo " Makefile -> $ksrc/Makefile.top"
- if [ $ksrc = svr4 ]; then
+ if [ "$ksrc" = svr4 ]; then
# Point to 64-bit Makefile extension
- if [ $lp64 = y ]; then
+ if [ "$lp64" = y ]; then
makext=$makext-64
fi
rm -f $ksrc/Makefile
ln -s Makefile.$makext $ksrc/Makefile
echo " $ksrc/Makefile -> Makefile.$makext"
# Restore extension
- if [ $lp64 = y ]; then
+ if [ "$lp64" = y ]; then
makext=$orig_makext
fi
fi