summaryrefslogtreecommitdiff
path: root/configure
diff options
context:
space:
mode:
authorAdi Masputra <adi.masputra@sun.com>1999-09-13 20:57:54 +0000
committerAdi Masputra <adi.masputra@sun.com>1999-09-13 20:57:54 +0000
commit5dda0611f339dbd66af82c1bdf5d34a62a044183 (patch)
treeda59da0bb13b13e0aa4bd5247f25b14dfaad79d9 /configure
parent97c99cb3b52be24977c72445766efdec1464b8f5 (diff)
Modifed configure to point to 64-bit Makefile extension for Sol 7 and later
Added sparcv9 subdirectory into svr4/.cvsignore Cleaned up svr4/Makefile.sol2 Added svr4/Makefile.sol2-64
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure b/configure
index cbb1d78..c8abdd5 100755
--- a/configure
+++ b/configure
@@ -1,5 +1,5 @@
#!/bin/sh
-# $Id: configure,v 1.17 1999/05/13 00:31:34 paulus Exp $
+# $Id: configure,v 1.18 1999/09/13 20:57:53 masputra Exp $
if [ -d /NextApps ]; then
system="NeXTStep"
@@ -24,7 +24,8 @@ case $system in
case $release in
[0-3]*) state="ancient";;
4*) state="known"; ksrc="sunos4"; makext="sunos4";;
- 5*) state="known"; ksrc="svr4"; makext="sol2";;
+ 5.[1-6]*) state="known"; ksrc="svr4"; makext="sol2";;
+ 5.[789]*) state="known"; ksrc="svr4"; makext="sol2"; lp64="y";
esac;;
ULTRIX)
makext="ultrix";
@@ -102,15 +103,25 @@ case $state in
echo "in this distribution. Sorry.";;
esac
+orig_makext=$makext
+
if [ -d "$ksrc" ]; then
echo "Creating links to Makefiles."
rm -f Makefile
ln -s $ksrc/Makefile.top Makefile
echo " Makefile -> $ksrc/Makefile.top"
if [ $ksrc = svr4 ]; then
+ # Point to 64-bit Makefile extension
+ if [ $lp64 = y ]; then
+ makext=$makext-64
+ fi
rm -f $ksrc/Makefile
ln -s Makefile.$makext $ksrc/Makefile
echo " $ksrc/Makefile -> Makefile.$makext"
+ # Restore extension
+ if [ $lp64 = y ]; then
+ makext=$orig_makext
+ fi
fi
for dir in pppd pppstats chat pppdump; do
rm -f $dir/Makefile