summaryrefslogtreecommitdiff
path: root/configure
diff options
context:
space:
mode:
authorPaul Mackerras <paulus@samba.org>1996-06-26 00:50:31 +0000
committerPaul Mackerras <paulus@samba.org>1996-06-26 00:50:31 +0000
commit5ec0e4da8c82337d8feea8c29b117271128e774d (patch)
treef6987a7144a6d740ebfd7b2683c9fcb222e2724e /configure
parent40f56b1dddffc7393022d7d4d31a360a8b2ce7f7 (diff)
check for port not being included
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure b/configure
index c519ead..c613558 100755
--- a/configure
+++ b/configure
@@ -1,5 +1,5 @@
#!/bin/sh
-# $Id: configure,v 1.8 1996/05/24 07:03:01 paulus Exp $
+# $Id: configure,v 1.9 1996/06/26 00:50:31 paulus Exp $
if [ -d /NextApps ]; then
system="NeXTStep"
@@ -35,6 +35,7 @@ case $system in
OSF1)
makext="osf";
case $release in
+ V1.*) state="ancient"; ksrc="osf1";;
V[23].*) state="known"; ksrc="osf1";;
V[4-9]*) state="late"; ksrc="osf1";;
esac;;
@@ -63,6 +64,11 @@ case $system in
esac;;
esac
+if [ -d $ksrc ]; then :; else
+ state="notincluded"
+ unset ksrc
+fi
+
case $state in
ancient)
echo "This is an old release of a supported OS ($system)."
@@ -78,9 +84,12 @@ case $state in
echo "this software was released. It may or may not work.";;
unknown)
echo "This software has not been ported to this system. Sorry.";;
+ notincluded)
+ echo "Support for this system has not been included"
+ echo "in this distribution. Sorry.";;
esac
-if [ $ksrc ]; then
+if [ "$ksrc" ]; then
echo "Creating links to Makefiles."
rm -f Makefile
ln -s $ksrc/Makefile.top Makefile