summaryrefslogtreecommitdiff
path: root/configure
diff options
context:
space:
mode:
authorPaul Mackerras <paulus@samba.org>2004-10-31 21:31:01 +0000
committerPaul Mackerras <paulus@samba.org>2004-10-31 21:31:01 +0000
commit9d2509710485b642dc4c61af7301c249110b4530 (patch)
treebeaaa538fa9fbae4c640b98823062b6ff656c610 /configure
parent8dab7e1cb378a55b57a7bca6bc66a7ecc091d41f (diff)
Cope better when prototype Makefiles don't exist.
Restore $archvariant stuff for solaris.
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure28
1 files changed, 14 insertions, 14 deletions
diff --git a/configure b/configure
index 2d7ea8d..88f93e6 100755
--- a/configure
+++ b/configure
@@ -1,5 +1,5 @@
#!/bin/sh
-# $Id: configure,v 1.32 2004/10/29 00:12:26 paulus Exp $
+# $Id: configure,v 1.33 2004/10/31 21:31:01 paulus Exp $
# Where to install stuff by default
DESTDIR=/usr/local
@@ -163,23 +163,23 @@ done
mkmkf() {
rm -f $2
- echo " $2 <= $1"
- sed -e "s,@DESTDIR@,$DESTDIR,g" -e "s,@SYSCONF@,$SYSCONF,g" $1 >$2
+ if [ -f $1 ]; then
+ echo " $2 <= $1"
+ sed -e "s,@DESTDIR@,$DESTDIR,g" -e "s,@SYSCONF@,$SYSCONF,g" $1 >$2
+ fi
}
if [ -d "$ksrc" ]; then
- echo "Creating Makefiles."
- mkmkf $ksrc/Makefile.top Makefile
- mkmkf $ksrc/Makedefs$compiletype Makedefs.com
- for dir in pppd pppstats chat pppdump pppd/plugins pppd/plugins/rp-pppoe \
- pppd/plugins/radius; do
- if [ -f $dir/Makefile.$makext ]; then
- mkmkf $dir/Makefile.$makext $dir/Makefile
+ echo "Creating Makefiles."
+ mkmkf $ksrc/Makefile.top Makefile
+ mkmkf $ksrc/Makedefs$compiletype Makedefs.com
+ for dir in pppd pppstats chat pppdump pppd/plugins pppd/plugins/rp-pppoe \
+ pppd/plugins/radius; do
+ mkmkf $dir/Makefile.$makext $dir/Makefile
+ done
+ if [ "$archvariant" ]; then
+ mkmkf Makefile.$makext$archvariant $ksrc/Makefile
fi
- done
- if [ "$archvariant" ]; then
- mkmkf Makefile.$makext $ksrc/Makefile
- fi
else
echo "Unable to locate kernel source $ksrc"
exit 1