summaryrefslogtreecommitdiff
path: root/configure
diff options
context:
space:
mode:
authorAdi Masputra <adi.masputra@sun.com>2000-04-18 23:51:29 +0000
committerAdi Masputra <adi.masputra@sun.com>2000-04-18 23:51:29 +0000
commitf9eac6e29b5137c46063855b3bfc253159c90c29 (patch)
treececff57292d63f00567d7d029b154fe943b09f0d /configure
parent56e6860d27306bcbe35b3a14f360d0f52b5940b5 (diff)
1) Created a subdirectory called 'solaris'. Currently it contains a replica
of the 'svr4' directory. However, over time, files in this directory will contain the same code as the kernel-portion of pppd in future releases of Solaris, hence they most probably will change in contents and/or sub-structure. 2) Changed the 'configure' script to not create symbolic link Makefiles when the OS is SunOS 4.x. Under 'SunOS' category, only SunOS 5.x (or Solaris 2.x) is currently enabled. 3) Changed the rest of the utilities + pppd daemon Makefile.sol2 to point to the solaris/Makedefs instead of the one in svr4 directory.
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure b/configure
index db318e0..1868308 100755
--- a/configure
+++ b/configure
@@ -1,5 +1,5 @@
#!/bin/sh
-# $Id: configure,v 1.24 2000/04/13 11:59:40 paulus Exp $
+# $Id: configure,v 1.25 2000/04/18 23:51:26 masputra Exp $
# if [ -d /NextApps ]; then
# system="NeXTStep"
@@ -18,10 +18,10 @@ case $system in
state="known";;
SunOS)
case $release in
- [0-3]*) state="ancient";;
- 4*) state="known"; ksrc="sunos4"; makext="sunos4";;
- 5.[1-6]*) state="known"; ksrc="svr4"; makext="sol2";;
- 5.[789]*) state="known"; ksrc="svr4"; makext="sol2";
+# [0-3]*) state="ancient";;
+# 4*) state="known"; ksrc="sunos4"; makext="sunos4";;
+ 5.[1-6]*) state="known"; ksrc="solaris"; makext="sol2";;
+ 5.[7-9]*) state="known"; ksrc="solaris"; makext="sol2";
case $arch in
sun4u) lp64='y';;
*) ;;
@@ -118,7 +118,7 @@ if [ -d "$ksrc" ]; then
rm -f Makefile
ln -s $ksrc/Makefile.top Makefile
echo " Makefile -> $ksrc/Makefile.top"
- if [ "$ksrc" = svr4 ]; then
+ if [ "$ksrc" = solaris ]; then
# Point to 64-bit Makefile extension
if [ "$lp64" = y ]; then
makext=$makext-64