summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorPaul Mackerras <paulus@samba.org>2006-06-04 05:07:46 +0000
committerPaul Mackerras <paulus@samba.org>2006-06-04 05:07:46 +0000
commitf59ff103bcb3096e4678625d4d0481f808fd4844 (patch)
tree244c81a365bf4309fe1fbfe7f85c1018fcf1d7fa /linux
parentd929a8d4e1d3e5ff15068ea3b538598b6d448943 (diff)
Add $(INSTDIR) to installation paths in Linux makefiles.
Patch from Robert Vogelgesang. This patch re-introduces the possibility for package maintainers to install into a different filesystem tree. This is done by adding $(INSTROOT) at various places; the package maintainers can then issue a make install INSTROOT=/some/where/else when they package pppd for their distribution. In previous versions of the ppp package this was possible using the variable DESTDIR, but this variable is now used for a different purpose and cannot be changed via additional parameters of the make command.
Diffstat (limited to 'linux')
-rw-r--r--linux/Makefile.top4
1 files changed, 2 insertions, 2 deletions
diff --git a/linux/Makefile.top b/linux/Makefile.top
index 55405f1..f63d45e 100644
--- a/linux/Makefile.top
+++ b/linux/Makefile.top
@@ -1,10 +1,10 @@
# PPP top-level Makefile for Linux.
-DESTDIR = @DESTDIR@
+DESTDIR = $(INSTROOT)@DESTDIR@
BINDIR = $(DESTDIR)/sbin
INCDIR = $(DESTDIR)/include
MANDIR = $(DESTDIR)/share/man
-ETCDIR = @SYSCONF@/ppp
+ETCDIR = $(INSTROOT)@SYSCONF@/ppp
# uid 0 = root
INSTALL= install