summaryrefslogtreecommitdiff
path: root/pppstats
diff options
context:
space:
mode:
authorPaul Mackerras <paulus@samba.org>2004-10-29 00:12:27 +0000
committerPaul Mackerras <paulus@samba.org>2004-10-29 00:12:27 +0000
commit93707a531320fbf398fdb5ffa69a86af092c798c (patch)
treeaf0956e848059d7716ce1ef358b932fa7af1c580 /pppstats
parent3d6b2e94e31ea1f49b81a4d1d4c2289d4058b26a (diff)
Add --prefix and --sysconfdir options to configure, and put
@DESTDIR@ and @SYSCONF@ tags in various Makefile.linux files. These tags get expanded by configure.
Diffstat (limited to 'pppstats')
-rw-r--r--pppstats/Makefile.linux11
1 files changed, 7 insertions, 4 deletions
diff --git a/pppstats/Makefile.linux b/pppstats/Makefile.linux
index 8bb4f9a..9b0a7e8 100644
--- a/pppstats/Makefile.linux
+++ b/pppstats/Makefile.linux
@@ -1,7 +1,10 @@
#
# pppstats makefile
-# $Id: Makefile.linux,v 1.5 2002/10/27 12:56:26 fcusack Exp $
+# $Id: Makefile.linux,v 1.6 2004/10/29 00:12:27 paulus Exp $
#
+DESTDIR = @DESTDIR@
+BINDIR = $(DESTDIR)/sbin
+MANDIR = $(DESTDIR)/man/man8
PPPSTATSRCS = pppstats.c
PPPSTATOBJS = pppstats.o
@@ -18,9 +21,9 @@ CFLAGS = $(COPTS) $(COMPILE_FLAGS)
all: pppstats
install: pppstats
- -mkdir -p $(MANDIR)/man8
- $(INSTALL) -s -c pppstats $(BINDIR)/pppstats
- $(INSTALL) -c -m 444 pppstats.8 $(MANDIR)/man8/pppstats.8
+ -mkdir -p $(MANDIR)
+ $(INSTALL) -s -c pppstats $(BINDIR)
+ $(INSTALL) -c -m 444 pppstats.8 $(MANDIR)
pppstats: $(PPPSTATSRCS)
$(CC) $(CFLAGS) -o pppstats pppstats.c $(LIBS)