summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-05-06 21:17:58 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-05-06 21:17:58 -0700
commitfd9162a8634ad3c1fd74adcee5e0b7870c186e91 (patch)
tree2906cbaa7cc1fc08bafe150838591a82b73fc78d /debian/rules
parentb2a80b6cd3748bd50afaa0d0bb795127e464d3de (diff)
begin using CDBS to build binary packages
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 9 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index ea15fad3..969bf21c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,15 @@
#!/usr/bin/make -f
+# don't install CHANGELOG as it duplicates d/changelog
+DEB_INSTALL_CHANGELOGS_ALL=
+
# Avoid using cabal, as it writes to $HOME
export CABAL=./Setup
-%:
- dh $@
-
-override_dh_auto_build:
+build/propellor::
$(MAKE) build
-override_dh_installchangelogs:
- dh_installchangelogs -XCHANGELOG
+install/propellor::
+ DESTDIR=$(CURDIR)/debian/propellor $(MAKE) install
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/hlibrary.mk