summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntony Pavlov <antonynpavlov@gmail.com>2017-01-21 19:18:14 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-21 19:18:25 +0000
commit52c8f1637d60a0d496571bd32f7ff7d64eeafc56 (patch)
tree1b020652a29c22c41437cc81f39ed0611f93bfbd
parent7258909993a99334740443749705dd921bb8a8fc (diff)
psmerge: Use ps2write.
It looks like psmerge from psutils-1.17.dfsg-3 still uses pswrite: $ dpkg -S /usr/bin/psmerge psutils: /usr/bin/psmerge $ dpkg -s psutils | grep '^Version:' Version: 1.17.dfsg-3 $ grep pswrite /usr/bin/psmerge exec +(qw(gs -q -dNOPAUSE -dBATCH -sDEVICE=pswrite), Changing "pswrite" to "ps2write" fixes the 'Unknown device: pswrite' problem, e\ .g. Closes:#797528. Reported-by: Kai-Martin Knaak <knaak@iqo.uni-hannover.de>
-rw-r--r--debian/changelog4
-rw-r--r--psmerge.pl2
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 97a16c8..cea63b2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,9 @@
psutils (1.17.dfsg-4~) unstable; urgency=medium
+ [ Antony Pavlov ]
+ * psmerge: Use ps2write. (pswrite is gone from gs.)
+ Closes:#797528.
+
[ Bjarni Ingi Gislason ]
* psnup(1): Fix manpage syntax error. Closes:#663258.
diff --git a/psmerge.pl b/psmerge.pl
index 7649358..4598a04 100644
--- a/psmerge.pl
+++ b/psmerge.pl
@@ -28,7 +28,7 @@ if (defined $gs)
{
# Just invoke gs
$outfile = '/dev/stdout' unless defined $outfile;
- exec +(qw(gs -q -dNOPAUSE -dBATCH -sDEVICE=pswrite),
+ exec +(qw(gs -q -dNOPAUSE -dBATCH -sDEVICE=ps2write),
"-sOutputFile=$outfile", '-f', @ARGV);
die "$prog: exec /usr/bin/gs failed\n";
}