summaryrefslogtreecommitdiff
path: root/bootstrap.sh
diff options
context:
space:
mode:
authorSjoerd Simons <sjoerd@debian.org>2011-08-10 16:19:28 +0200
committerSjoerd Simons <sjoerd@debian.org>2011-08-10 16:19:28 +0200
commitc9e69b0e35d5242394d371ea5576f430ece3eeeb (patch)
tree06270a7839d2d858ed7900fdc05e366f2dcfd6d6 /bootstrap.sh
parentdba33e466e17070333b7f587b07a47dcf5037f8c (diff)
Imported Upstream version 0.99.1
Diffstat (limited to 'bootstrap.sh')
-rwxr-xr-xbootstrap.sh14
1 files changed, 9 insertions, 5 deletions
diff --git a/bootstrap.sh b/bootstrap.sh
index c7c8582..d0baf95 100755
--- a/bootstrap.sh
+++ b/bootstrap.sh
@@ -45,6 +45,7 @@ case $(uname) in
LIBTOOLIZE="glibtoolize"
;;
esac
+test "x$LIBTOOLIZE" = "x" && LIBTOOLIZE=libtoolize
if [ -f .git/hooks/pre-commit.sample -a ! -f .git/hooks/pre-commit ] ; then
cp -p .git/hooks/pre-commit.sample .git/hooks/pre-commit && \
@@ -63,9 +64,15 @@ fi
# configure file faulty.
if ! pkg-config --version &>/dev/null; then
echo "pkg-config is required to bootstrap this program" &>/dev/null
- exit 1
+ DIE=1
fi
+# Other necessary programs
+glib-gettextize --version >/dev/null || DIE=1
+intltoolize --version >/dev/null || DIE=1
+$LIBTOOLIZE --version >/dev/null || DIE=1
+test "$DIE" = 1 && exit 1
+
if type -p colorgcc > /dev/null ; then
export CC=colorgcc
fi
@@ -78,14 +85,11 @@ else
rm -f config.cache
rm -f Makefile.am~ configure.ac~
- # Evil, evil, evil, evil hack
- sed 's/read dummy/\#/' `which gettextize` | bash -s -- --copy --force
+ glib-gettextize --copy --force
test -f Makefile.am~ && mv Makefile.am~ Makefile.am
test -f configure.ac~ && mv configure.ac~ configure.ac
touch config.rpath
- test "x$LIBTOOLIZE" = "x" && LIBTOOLIZE=libtoolize
-
intltoolize --copy --force --automake
"$LIBTOOLIZE" -c --force
run_versioned aclocal "$VERSION" -I m4