summaryrefslogtreecommitdiff
path: root/configure
diff options
context:
space:
mode:
authorFelipe Sateler <fsateler@debian.org>2015-09-03 21:25:43 -0300
committerFelipe Sateler <fsateler@debian.org>2015-09-03 21:25:43 -0300
commit78ff69dcedeb9e110642d904dee2cc50fcf23c14 (patch)
treee1ccd77d8f39e9ab1a82c0474e9ef1dcd97eedff /configure
parent03f5d80e9f5042a3926876833227f2abf250d735 (diff)
Imported Upstream version 6.99.1
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure182
1 files changed, 163 insertions, 19 deletions
diff --git a/configure b/configure
index a3c0fa4..c1ad56b 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for pulseaudio 6.0.
+# Generated by GNU Autoconf 2.69 for pulseaudio 6.99.1.
#
# Report bugs to <pulseaudio-discuss (at) lists (dot) freedesktop (dot) org>.
#
@@ -590,8 +590,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='pulseaudio'
PACKAGE_TARNAME='pulseaudio'
-PACKAGE_VERSION='6.0'
-PACKAGE_STRING='pulseaudio 6.0'
+PACKAGE_VERSION='6.99.1'
+PACKAGE_STRING='pulseaudio 6.99.1'
PACKAGE_BUGREPORT='pulseaudio-discuss (at) lists (dot) freedesktop (dot) org'
PACKAGE_URL='http://pulseaudio.org/'
@@ -644,6 +644,7 @@ PA_LIBDIR
FORCE_PREOPEN_FALSE
FORCE_PREOPEN_TRUE
zshcompletiondir
+bashcompletiondir
udevrulesdir
PA_DLSEARCHPATH
modlibexecdir
@@ -707,6 +708,10 @@ HAVE_XEN_FALSE
HAVE_XEN_TRUE
XEN_LIBS
XEN_CFLAGS
+HAVE_SOXR_FALSE
+HAVE_SOXR_TRUE
+LIBSOXR_LIBS
+LIBSOXR_CFLAGS
HAVE_SPEEX_FALSE
HAVE_SPEEX_TRUE
LIBSPEEX_LIBS
@@ -1099,6 +1104,7 @@ enable_ipv6
enable_openssl
with_fftw
with_speex
+with_soxr
enable_xen
enable_gcov
enable_orc
@@ -1122,6 +1128,7 @@ enable_static_bins
with_preopen_mods
with_module_dir
with_udev_rules_dir
+with_bash_completion_dir
with_zsh_completion_dir
enable_force_preopen
'
@@ -1181,6 +1188,8 @@ FFTW_CFLAGS
FFTW_LIBS
LIBSPEEX_CFLAGS
LIBSPEEX_LIBS
+LIBSOXR_CFLAGS
+LIBSOXR_LIBS
ORC_CFLAGS
ORC_LIBS
SYSTEMD_CFLAGS
@@ -1733,7 +1742,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures pulseaudio 6.0 to adapt to many kinds of systems.
+\`configure' configures pulseaudio 6.99.1 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1803,7 +1812,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of pulseaudio 6.0:";;
+ short | recursive ) echo "Configuration of pulseaudio 6.99.1:";;
esac
cat <<\_ACEOF
@@ -1905,6 +1914,7 @@ Optional Packages:
Choose database backend.
--without-fftw Omit FFTW-using modules (equalizer)
--without-speex Omit speex (resampling, AEC)
+ --without-soxr Omit soxr (resampling)
--with-systemduserunitdir=DIR
Directory for systemd user service files
--with-system-user=<user>
@@ -1927,6 +1937,8 @@ Optional Packages:
to ${libdir}/pulse-${PA_MAJORMINOR}/modules
--with-udev-rules-dir Directory where to install udev rules to (defaults
to /lib/udev/rules.d)
+ --with-bash-completion-dir=DIR
+ Directory for bash completion files
--with-zsh-completion-dir
Zsh completions directory (defaults to
${datadir}/zsh/site-functions)
@@ -2009,6 +2021,10 @@ Some influential environment variables:
C compiler flags for LIBSPEEX, overriding pkg-config
LIBSPEEX_LIBS
linker flags for LIBSPEEX, overriding pkg-config
+ LIBSOXR_CFLAGS
+ C compiler flags for LIBSOXR, overriding pkg-config
+ LIBSOXR_LIBS
+ linker flags for LIBSOXR, overriding pkg-config
ORC_CFLAGS C compiler flags for ORC, overriding pkg-config
ORC_LIBS linker flags for ORC, overriding pkg-config
SYSTEMD_CFLAGS
@@ -2098,7 +2114,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-pulseaudio configure 6.0
+pulseaudio configure 6.99.1
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -2688,7 +2704,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by pulseaudio $as_me 6.0, which was
+It was created by pulseaudio $as_me 6.99.1, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -3154,7 +3170,7 @@ ac_config_sub="$SHELL $ac_aux_dir/config.sub" # Please don't use this var.
ac_configure="$SHELL $ac_aux_dir/configure" # Please don't use this var.
-am__api_version='1.14'
+am__api_version='1.15'
# Find a good install program. We prefer a C program (faster),
# so one script is as good as another. But avoid the broken or
@@ -3326,8 +3342,8 @@ test "$program_suffix" != NONE &&
ac_script='s/[\\$]/&&/g;s/;s,x,x,$//'
program_transform_name=`$as_echo "$program_transform_name" | sed "$ac_script"`
-# expand $ac_aux_dir to an absolute path
-am_aux_dir=`cd $ac_aux_dir && pwd`
+# Expand $ac_aux_dir to an absolute path.
+am_aux_dir=`cd "$ac_aux_dir" && pwd`
if test x"${MISSING+set}" != xset; then
case $am_aux_dir in
@@ -3346,7 +3362,7 @@ else
$as_echo "$as_me: WARNING: 'missing' script is too old or missing" >&2;}
fi
-if test x"${install_sh}" != xset; then
+if test x"${install_sh+set}" != xset; then
case $am_aux_dir in
*\ * | *\ *)
install_sh="\${SHELL} '$am_aux_dir/install-sh'" ;;
@@ -3640,7 +3656,7 @@ fi
# Define the identity of the package.
PACKAGE='pulseaudio'
- VERSION='6.0'
+ VERSION='6.99.1'
cat >>confdefs.h <<_ACEOF
@@ -3674,8 +3690,8 @@ MAKEINFO=${MAKEINFO-"${am_missing_run}makeinfo"}
# <http://lists.gnu.org/archive/html/automake/2012-07/msg00014.html>
mkdir_p='$(MKDIR_P)'
-# We need awk for the "check" target. The system "awk" is bad on
-# some platforms.
+# We need awk for the "check" target (and possibly the TAP driver). The
+# system "awk" is bad on some platforms.
# Always define AMTAR for backward compatibility. Yes, it's still used
# in the wild :-( We should find a proper way to deprecate it ...
AMTAR='$${TAR-tar}'
@@ -3849,6 +3865,7 @@ END
fi
fi
+
if ! test -n "$VERSION"; then :
as_fn_error $? "git-version-gen failed" "$LINENO" 5
@@ -3872,7 +3889,7 @@ PA_PROTOCOL_VERSION=30
# The stable ABI for client applications, for the version info x:y:z
# always will hold y=z
-LIBPULSE_VERSION_INFO=18:0:18
+LIBPULSE_VERSION_INFO=18:1:18
# A simplified, synchronous, ABI-stable interface for client
@@ -26619,6 +26636,109 @@ $as_echo "#define HAVE_SPEEX 1" >>confdefs.h
fi
+#### soxr (optional) ####
+
+
+# Check whether --with-soxr was given.
+if test "${with_soxr+set}" = set; then :
+ withval=$with_soxr;
+fi
+
+
+if test "x$with_soxr" != "xno"; then :
+
+pkg_failed=no
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for LIBSOXR" >&5
+$as_echo_n "checking for LIBSOXR... " >&6; }
+
+if test -n "$LIBSOXR_CFLAGS"; then
+ pkg_cv_LIBSOXR_CFLAGS="$LIBSOXR_CFLAGS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \" soxr >= 0.1.1 \""; } >&5
+ ($PKG_CONFIG --exists --print-errors " soxr >= 0.1.1 ") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+ pkg_cv_LIBSOXR_CFLAGS=`$PKG_CONFIG --cflags " soxr >= 0.1.1 " 2>/dev/null`
+ test "x$?" != "x0" && pkg_failed=yes
+else
+ pkg_failed=yes
+fi
+ else
+ pkg_failed=untried
+fi
+if test -n "$LIBSOXR_LIBS"; then
+ pkg_cv_LIBSOXR_LIBS="$LIBSOXR_LIBS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \" soxr >= 0.1.1 \""; } >&5
+ ($PKG_CONFIG --exists --print-errors " soxr >= 0.1.1 ") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+ pkg_cv_LIBSOXR_LIBS=`$PKG_CONFIG --libs " soxr >= 0.1.1 " 2>/dev/null`
+ test "x$?" != "x0" && pkg_failed=yes
+else
+ pkg_failed=yes
+fi
+ else
+ pkg_failed=untried
+fi
+
+
+
+if test $pkg_failed = yes; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+
+if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
+ _pkg_short_errors_supported=yes
+else
+ _pkg_short_errors_supported=no
+fi
+ if test $_pkg_short_errors_supported = yes; then
+ LIBSOXR_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs " soxr >= 0.1.1 " 2>&1`
+ else
+ LIBSOXR_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs " soxr >= 0.1.1 " 2>&1`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$LIBSOXR_PKG_ERRORS" >&5
+
+ HAVE_SOXR=0
+elif test $pkg_failed = untried; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+ HAVE_SOXR=0
+else
+ LIBSOXR_CFLAGS=$pkg_cv_LIBSOXR_CFLAGS
+ LIBSOXR_LIBS=$pkg_cv_LIBSOXR_LIBS
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+$as_echo "yes" >&6; }
+ HAVE_SOXR=1
+fi
+else
+ HAVE_SOXR=0
+fi
+
+if test "x$with_soxr" = "xyes" && test "x$HAVE_SOXR" = "x0"; then :
+ as_fn_error $? "*** soxr support not found" "$LINENO" 5
+fi
+
+ if test "x$HAVE_SOXR" = "x1"; then
+ HAVE_SOXR_TRUE=
+ HAVE_SOXR_FALSE='#'
+else
+ HAVE_SOXR_TRUE='#'
+ HAVE_SOXR_FALSE=
+fi
+
+if test "x$HAVE_SOXR" = "x1"; then :
+
+$as_echo "#define HAVE_SOXR 1" >>confdefs.h
+
+fi
+
#### Xen support (optional) ####
# Check whether --enable-xen was given.
@@ -27838,6 +27958,20 @@ fi
+# Check whether --with-bash-completion-dir was given.
+if test "${with_bash_completion_dir+set}" = set; then :
+ withval=$with_bash_completion_dir; bashcompletiondir=$withval
+else
+ bashcompletiondir=$($PKG_CONFIG --variable=completionsdir bash-completion)
+fi
+
+if test "x$bashcompletionsdir" = ""; then
+ bashcompletiondir="${datadir}/bash-completion/completions"
+fi
+
+
+
+
# Check whether --with-zsh-completion-dir was given.
if test "${with_zsh_completion_dir+set}" = set; then :
withval=$with_zsh_completion_dir; zshcompletiondir=$withval
@@ -27869,7 +28003,7 @@ else
fi
-ac_config_files="$ac_config_files Makefile src/Makefile man/Makefile libpulse.pc libpulse-simple.pc libpulse-mainloop-glib.pc doxygen/Makefile doxygen/doxygen.conf src/pulse/version.h po/Makefile.in man/pulseaudio.1.xml man/esdcompat.1.xml man/pax11publish.1.xml man/paplay.1.xml man/pacat.1.xml man/pacmd.1.xml man/pactl.1.xml man/pasuspender.1.xml man/padsp.1.xml man/pulse-daemon.conf.5.xml man/pulse-client.conf.5.xml man/default.pa.5.xml man/pulse-cli-syntax.5.xml man/start-pulseaudio-x11.1.xml"
+ac_config_files="$ac_config_files Makefile src/Makefile man/Makefile libpulse.pc libpulse-simple.pc libpulse-mainloop-glib.pc doxygen/Makefile doxygen/doxygen.conf src/pulse/version.h po/Makefile.in man/pulseaudio.1.xml man/esdcompat.1.xml man/pax11publish.1.xml man/pacat.1.xml man/pacmd.1.xml man/pactl.1.xml man/pasuspender.1.xml man/padsp.1.xml man/pulse-daemon.conf.5.xml man/pulse-client.conf.5.xml man/default.pa.5.xml man/pulse-cli-syntax.5.xml man/start-pulseaudio-x11.1.xml"
ac_config_files="$ac_config_files src/esdcompat:src/daemon/esdcompat.in"
@@ -28240,6 +28374,10 @@ if test -z "${HAVE_SPEEX_TRUE}" && test -z "${HAVE_SPEEX_FALSE}"; then
as_fn_error $? "conditional \"HAVE_SPEEX\" was never defined.
Usually this means the macro was only invoked conditionally." "$LINENO" 5
fi
+if test -z "${HAVE_SOXR_TRUE}" && test -z "${HAVE_SOXR_FALSE}"; then
+ as_fn_error $? "conditional \"HAVE_SOXR\" was never defined.
+Usually this means the macro was only invoked conditionally." "$LINENO" 5
+fi
if test -z "${HAVE_XEN_TRUE}" && test -z "${HAVE_XEN_FALSE}"; then
as_fn_error $? "conditional \"HAVE_XEN\" was never defined.
Usually this means the macro was only invoked conditionally." "$LINENO" 5
@@ -28693,7 +28831,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by pulseaudio $as_me 6.0, which was
+This file was extended by pulseaudio $as_me 6.99.1, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -28760,7 +28898,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-pulseaudio config.status 6.0
+pulseaudio config.status 6.99.1
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
@@ -29290,7 +29428,6 @@ do
"man/pulseaudio.1.xml") CONFIG_FILES="$CONFIG_FILES man/pulseaudio.1.xml" ;;
"man/esdcompat.1.xml") CONFIG_FILES="$CONFIG_FILES man/esdcompat.1.xml" ;;
"man/pax11publish.1.xml") CONFIG_FILES="$CONFIG_FILES man/pax11publish.1.xml" ;;
- "man/paplay.1.xml") CONFIG_FILES="$CONFIG_FILES man/paplay.1.xml" ;;
"man/pacat.1.xml") CONFIG_FILES="$CONFIG_FILES man/pacat.1.xml" ;;
"man/pacmd.1.xml") CONFIG_FILES="$CONFIG_FILES man/pacmd.1.xml" ;;
"man/pactl.1.xml") CONFIG_FILES="$CONFIG_FILES man/pactl.1.xml" ;;
@@ -31144,6 +31281,11 @@ if test "x$HAVE_SPEEX" = "x1"; then :
else
ENABLE_SPEEX=no
fi
+if test "x$HAVE_SOXR" = "x1"; then :
+ ENABLE_SOXR=yes
+else
+ ENABLE_SOXR=no
+fi
if test "x$HAVE_WEBRTC" = "x1"; then :
ENABLE_WEBRTC=yes
else
@@ -31201,6 +31343,7 @@ echo "
System State Path: ${PA_SYSTEM_STATE_PATH}
System Config Path: ${PA_SYSTEM_CONFIG_PATH}
Zsh completions directory: ${zshcompletiondir}
+ Bash completions directory: ${bashcompletiondir}
Compiler: ${CC}
CFLAGS: ${CFLAGS}
CPPFLAGS: ${CPPFLAGS}
@@ -31241,6 +31384,7 @@ echo "
Enable orc: ${ENABLE_ORC}
Enable Adrian echo canceller: ${ENABLE_ADRIAN_EC}
Enable speex (resampler, AEC): ${ENABLE_SPEEX}
+ Enable soxr (resampler): ${ENABLE_SOXR}
Enable WebRTC echo canceller: ${ENABLE_WEBRTC}
Enable gcov coverage: ${ENABLE_GCOV}
Enable unit tests: ${ENABLE_TESTS}