summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSandro Tosi <morph@debian.org>2019-12-20 15:56:26 -0500
committerAndrej Shadura <andrew.shadura@collabora.co.uk>2020-03-16 18:53:23 +0100
commitb63d0af93f7c14f5c6beb7f28abe60ea91841283 (patch)
treed3acd30357506c789c3dfeee9608b23e678e6be8
parent86ff3839eb698a4289f8d9ab2b4d162f45d4a059 (diff)
Drop python2 support
Closes: #937471
-rw-r--r--debian/changelog7
-rw-r--r--debian/control15
-rwxr-xr-xdebian/rules2
3 files changed, 8 insertions, 16 deletions
diff --git a/debian/changelog b/debian/changelog
index c669543..aba0d4a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+py-lmdb (0.86-1.2) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Drop python2 support; Closes: #937471
+
+ -- Sandro Tosi <morph@debian.org> Fri, 20 Dec 2019 15:56:26 -0500
+
py-lmdb (0.86-1.1) unstable; urgency=medium
* Non-maintainer upload.
diff --git a/debian/control b/debian/control
index 61e41af..4c32a47 100644
--- a/debian/control
+++ b/debian/control
@@ -7,28 +7,13 @@ Build-Depends:
debhelper (>= 9~)
, dh-python
, liblmdb-dev
- , python-all-dev
, python3-all-dev
- , python-setuptools
, python3-setuptools
Standards-Version: 3.9.6
Homepage: https://github.com/dw/py-lmdb
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-db/py-lmdb.git/
Vcs-Git: git://anonscm.debian.org/pkg-db/py-lmdb.git
-Package: python-lmdb
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, ${python:Depends}
-Description: Python binding for LMDB Lightning Memory-Mapped Database
- Lighting Memory-Mapped Database (LMDB) is an ultra-fast, ultra-compact
- key-value embedded data store developed for the OpenLDAP Project. It uses
- memory-mapped files, so it has the read performance of a pure in-memory
- database while still offering the persistence of standard disk-based
- databases, and is only limited to the size of the virtual address space (it
- is not limited to the size of physical RAM).
- .
- This package contains the 'lmdb' Python extension module.
-
Package: python3-lmdb
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, ${python3:Depends}
diff --git a/debian/rules b/debian/rules
index 02d1514..3dc7cc1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,7 +5,7 @@ export LMDB_FORCE_SYSTEM=1
export PYBUILD_NAME=lmdb
%:
- dh $@ --with python2,python3 --buildsystem=pybuild
+ dh $@ --with python3 --buildsystem=pybuild
override_dh_auto_clean:
dh_auto_clean