summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2023-02-28 09:34:57 +0000
committerColin Watson <cjwatson@debian.org>2023-02-28 09:34:57 +0000
commita702364a8fe40311bfbe85946b2bdaf3cfc5ffe2 (patch)
tree46be59e17bcb8d4473e4c134f94bb561b1f82579
parent8f5181d214290c6d8d8d37ffd6c96d71c290b1b5 (diff)
Fix saving macaroons to MozillaCookieJar() on Python 3.10
LP: #1970267
-rw-r--r--debian/changelog5
-rw-r--r--debian/patches/fix-saving-macaroons-in-mozillacookiejar.patch25
-rw-r--r--debian/patches/series1
3 files changed, 31 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 1cce516..f429e39 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,12 @@
py-macaroon-bakery (1.3.1-5) UNRELEASED; urgency=medium
+ [ Colin Watson ]
* Set upstream metadata fields: Repository.
+ [ Steve Beattie ]
+ * Fix saving macaroons to MozillaCookieJar() on Python 3.10
+ (LP: #1970267).
+
-- Colin Watson <cjwatson@debian.org> Mon, 02 Jan 2023 13:58:13 -0000
py-macaroon-bakery (1.3.1-4) unstable; urgency=medium
diff --git a/debian/patches/fix-saving-macaroons-in-mozillacookiejar.patch b/debian/patches/fix-saving-macaroons-in-mozillacookiejar.patch
new file mode 100644
index 0000000..f4deb3b
--- /dev/null
+++ b/debian/patches/fix-saving-macaroons-in-mozillacookiejar.patch
@@ -0,0 +1,25 @@
+From: Steve Beattie <steve.beattie@canonical.com>
+Date: Tue, 28 Feb 2023 09:27:58 +0000
+Subject: Fix saving macaroons in MozillaCookieJar() on Python 3.10
+
+Origin: other, https://github.com/go-macaroon-bakery/py-macaroon-bakery/issues/88#issue-1214739879
+Bug: https://github.com/go-macaroon-bakery/py-macaroon-bakery/issues/88
+Reviewed-by: Alex Murray <alex.murray@canonical.com>
+Last-Update: 2023-02-28
+---
+ macaroonbakery/_utils/__init__.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/macaroonbakery/_utils/__init__.py b/macaroonbakery/_utils/__init__.py
+index 977cdbe..d1afe31 100644
+--- a/macaroonbakery/_utils/__init__.py
++++ b/macaroonbakery/_utils/__init__.py
+@@ -160,7 +160,7 @@ def cookie(
+ discard=False,
+ comment=None,
+ comment_url=None,
+- rest=None,
++ rest={},
+ rfc2109=False,
+ )
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..a66820f
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+fix-saving-macaroons-in-mozillacookiejar.patch