summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2017-12-12 15:20:49 +0000
committerColin Watson <cjwatson@debian.org>2017-12-12 15:20:49 +0000
commit9e4403035a9953c99117083e6373ae3c441a76b5 (patch)
treed91b137df6767bfb8cb72de6b9fd21efb0c3dee4 /Makefile
parent949b7072cabce0daed6c94993ad44c8ea8648dbd (diff)
Import py-macaroon-bakery_1.1.0.orig.tar.gz
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 75d0e27..8466ce9 100644
--- a/Makefile
+++ b/Makefile
@@ -33,8 +33,7 @@ endif
.PHONY: check
-check: setup
- @tox -e lint
+check: setup lint
@tox
.PHONY: clean
@@ -54,7 +53,7 @@ clean:
.PHONY: docs
docs: setup
- tox -e docs
+ @tox -e docs
.PHONY: help
help:
@@ -76,7 +75,7 @@ help:
.PHONY: lint
lint: setup
- @$(DEVENV)/bin/flake8 --show-source macaroonbakery --exclude macaroonbakery/internal/id_pb2.py
+ @tox -e lint
.PHONY: release
release: check
@@ -97,3 +96,11 @@ test: setup
@$(DEVENV)/bin/nosetests \
--verbosity 2 --with-coverage --cover-erase \
--cover-package macaroonbakery
+
+.PHONY: isort
+isort:
+ isort \
+ --trailing-comma \
+ --recursive \
+ --multi-line 3 \
+ `find macaroonbakery -name '*.py' | grep -v 'internal/id_pb2\.py'`