summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py27
1 files changed, 8 insertions, 19 deletions
diff --git a/setup.py b/setup.py
index f098e76..d549aa5 100755
--- a/setup.py
+++ b/setup.py
@@ -2,9 +2,6 @@
# Copyright 2017 Canonical Ltd.
# Licensed under the LGPLv3, see LICENCE file for details.
-import sys
-import platform
-
from setuptools import (
find_packages,
setup,
@@ -13,8 +10,8 @@ from setuptools import (
PROJECT_NAME = 'macaroonbakery'
-# version 1.2.3
-VERSION = (1, 2, 3)
+# version 1.3.0
+VERSION = (1, 3, 0)
def get_version():
@@ -32,27 +29,19 @@ requirements = [
'six>=1.11.0,<2.0',
'protobuf>=3.0.0,<4.0',
'pyRFC3339>=1.0,<2.0',
+ 'ipaddress;python_version<"3"',
+ 'cryptography==1.3.2;python_full_version<"2.7.9"',
+ 'ndg_httpsclient==0.3.3;python_full_version<"2.7.9"',
+ 'pyasn1==0.1.9;python_full_version<"2.7.9"',
+ 'pyOpenSSL==16.0.0;python_full_version<"2.7.9"',
]
test_requirements = [
'tox',
+ 'fixtures',
'httmock==1.2.5',
]
-distribution = platform.dist()
-if len(distribution) == 3 and distribution[2] == 'trusty':
- # Injected into urllib3 to fix insecure Python 2.
- requirements.extend([
- 'cryptography==1.3.2',
- 'pyOpenSSL==16.0.0',
- 'pyasn1==0.1.9',
- 'ndg_httpsclient==0.3.3',
- ])
-
-if sys.version_info.major == 2:
- requirements.append('ipaddress')
-
-
setup(
name=PROJECT_NAME,
version=get_version(),