summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpataquets <amontero@tinet.org>2013-09-08 22:14:20 +0200
committerpataquets <amontero@tinet.org>2013-09-08 22:14:20 +0200
commitb4d941f077046f78fa2cfd3701c304d1ae7ae615 (patch)
tree93fda3720f6542ee59fe2c3b80b0751c6d8b6c8a
parentf789ed951b49b33e7cc49d16fdc8b398f7ec7223 (diff)
Create .travis.yml
Based on tahoe-lafs one.
-rw-r--r--.travis.yml17
1 files changed, 17 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..fabbe70
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,17 @@
+language: python
+python:
+ - "2.7"
+ - "2.6"
+before_install:
+ - sh -c set
+install: true
+script: python setup.py test
+notifications:
+ email: false
+ irc:
+ channels: "chat.freenode.net#tahoe-lafs"
+ on_success: always # for testing
+ on_failure: always
+ template:
+ - "%{repository}#%{build_number} [%{branch}: %{commit} by %{author}] %{message}"
+ - "Changes: %{compare_url} | Details: %{build_url}"