summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml17
1 files changed, 17 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..fabbe70
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,17 @@
+language: python
+python:
+ - "2.7"
+ - "2.6"
+before_install:
+ - sh -c set
+install: true
+script: python setup.py test
+notifications:
+ email: false
+ irc:
+ channels: "chat.freenode.net#tahoe-lafs"
+ on_success: always # for testing
+ on_failure: always
+ template:
+ - "%{repository}#%{build_number} [%{branch}: %{commit} by %{author}] %{message}"
+ - "Changes: %{compare_url} | Details: %{build_url}"