summaryrefslogtreecommitdiff
path: root/debian/patches/noextraversion.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/noextraversion.patch')
-rw-r--r--debian/patches/noextraversion.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/debian/patches/noextraversion.patch b/debian/patches/noextraversion.patch
new file mode 100644
index 0000000..85325b5
--- /dev/null
+++ b/debian/patches/noextraversion.patch
@@ -0,0 +1,40 @@
+Description: Comment out version calculating logic
+ Since the required file for this logic is missing this will break the build.
+ This should be dropped once the version logic is fixed upstream.
+Author: Micah Anderson <micah@riseup.net>
+Last-Updated: 2016-11-12
+Forwarded: not-needed
+diff --git a/setup.py b/setup.py
+index e4fb8b4..00ddd18 100644
+--- a/setup.py
++++ b/setup.py
+@@ -266,7 +266,7 @@ def read_version_py(infname):
+ if mo:
+ return mo.group(1)
+
+-EXTRAVERSION_H_FNAME = os.path.join(EMBEDDED_CRYPTOPP_DIR, 'extraversion.h')
++#EXTRAVERSION_H_FNAME = os.path.join(EMBEDDED_CRYPTOPP_DIR, 'extraversion.h')
+
+ VERSION_BODY = '''
+ # This is the version of this tree, as created by %(versiontool)s from the
+@@ -297,13 +297,13 @@ class UpdateVersion(object):
+ # Let's avoid touching the change time (ctime) on the files unless
+ # they actually need to be updated.
+
+- if self.read_extraversion_h(EXTRAVERSION_H_FNAME) != version:
+- self.write_extraversion_h(
+- PKG,
+- version,
+- EXTRAVERSION_H_FNAME,
+- CPP_GIT_VERSION_BODY
+- )
++# if self.read_extraversion_h(EXTRAVERSION_H_FNAME) != version:
++# self.write_extraversion_h(
++# PKG,
++# version,
++# EXTRAVERSION_H_FNAME,
++# CPP_GIT_VERSION_BODY
++# )
+
+ if read_version_py(VERSION_PY_FNAME) != version:
+ self.write_version_py(