summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2019-05-28 11:59:11 +0200
committerPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2019-05-28 12:01:43 +0200
commit2225a6c6ff3965231f3884c8c6043c68c78ecd8d (patch)
treedf5e89c91d7045a44e9b7ed50d6d79220a9ac2b1
parent17a9e533f23ad8fbb6fd1e7da402b4dd84831451 (diff)
refresh the patch series
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/0003-remove-a-wrong-PYTHONPATH-modification.patch4
-rw-r--r--debian/patches/0004-Skipped-unittests-for-i386-arch.patch34
-rw-r--r--debian/patches/0004-unactive-script-test.patch22
-rw-r--r--debian/patches/0005-Swapped-fvisibility-and-D.patch21
-rw-r--r--debian/patches/0005-fix-the-setup-dependencies.patch36
-rw-r--r--debian/patches/0006-Hid-ext-args-to-try-to-fix-FTBFS.patch23
-rw-r--r--debian/patches/series4
8 files changed, 39 insertions, 107 deletions
diff --git a/debian/changelog b/debian/changelog
index f7e6c04..3dc9aef 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,8 @@ pyfai (0.18.0+dfsg1-1~exp1) experimental; urgency=medium
- Build-Depends on python[3]-silx[-dbg] >= 0.10.1
- Bumped Standards-Version 4.3.0 (nothing to do)
- Switched to compat level 11
+ * d/patches
+ - Refreshed
-- Picca Frédéric-Emmanuel <picca@debian.org> Tue, 28 May 2019 11:26:33 +0200
diff --git a/debian/patches/0003-remove-a-wrong-PYTHONPATH-modification.patch b/debian/patches/0003-remove-a-wrong-PYTHONPATH-modification.patch
index f4b486d..2b8e99c 100644
--- a/debian/patches/0003-remove-a-wrong-PYTHONPATH-modification.patch
+++ b/debian/patches/0003-remove-a-wrong-PYTHONPATH-modification.patch
@@ -8,10 +8,10 @@ Subject: remove a wrong PYTHONPATH modification
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
-index 53170e0..8d742c1 100644
+index 525b2c4..f711f91 100644
--- a/setup.py
+++ b/setup.py
-@@ -294,7 +294,7 @@ class BuildMan(Command):
+@@ -300,7 +300,7 @@ class BuildMan(Command):
path.insert(0, os.path.abspath(build.build_lib))
env = dict((str(k), str(v)) for k, v in os.environ.items())
diff --git a/debian/patches/0004-Skipped-unittests-for-i386-arch.patch b/debian/patches/0004-Skipped-unittests-for-i386-arch.patch
deleted file mode 100644
index 66122f5..0000000
--- a/debian/patches/0004-Skipped-unittests-for-i386-arch.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From: Alexandre Marie <alexandre.marie@synchrotron-soleil.fr>
-Date: Mon, 7 Jan 2019 16:16:43 +0100
-Subject: Skipped unittests for i386 arch
-
----
- pyFAI/test/test_openCL.py | 2 +-
- pyFAI/test/test_split_pixel.py | 1 +
- 2 files changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/pyFAI/test/test_openCL.py b/pyFAI/test/test_openCL.py
-index a12646b..a9d7256 100644
---- a/pyFAI/test/test_openCL.py
-+++ b/pyFAI/test/test_openCL.py
-@@ -506,7 +506,7 @@ def suite():
- loader = unittest.defaultTestLoader.loadTestsFromTestCase
- testsuite.addTest(loader(TestMask))
- testsuite.addTest(loader(TestSort))
-- testsuite.addTest(loader(TestKahan))
-+ # testsuite.addTest(loader(TestKahan))
- return testsuite
-
-
-diff --git a/pyFAI/test/test_split_pixel.py b/pyFAI/test/test_split_pixel.py
-index c1ff035..e3b45cb 100644
---- a/pyFAI/test/test_split_pixel.py
-+++ b/pyFAI/test/test_split_pixel.py
-@@ -178,6 +178,7 @@ class TestSplitBBoxNg(unittest.TestCase):
- cls.results = None
- cls.img = None
-
-+ @unittest.skip("failed on debian i386")
- def test_split_bbox_2d(self):
- # radial position:
- tth_legacy = self.results["histoBBox2d_legacy"][1]
diff --git a/debian/patches/0004-unactive-script-test.patch b/debian/patches/0004-unactive-script-test.patch
new file mode 100644
index 0000000..1d356ed
--- /dev/null
+++ b/debian/patches/0004-unactive-script-test.patch
@@ -0,0 +1,22 @@
+From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?=
+ <picca@synchrotron-soleil.fr>
+Date: Sat, 3 Feb 2018 11:19:42 +0100
+Subject: unactive script test
+
+---
+ pyFAI/test/test_all.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pyFAI/test/test_all.py b/pyFAI/test/test_all.py
+index 97046af..522fd05 100644
+--- a/pyFAI/test/test_all.py
++++ b/pyFAI/test/test_all.py
+@@ -140,7 +140,7 @@ def suite():
+ testsuite.addTest(test_utils_ellipse.suite())
+ testsuite.addTest(test_preproc.suite())
+ testsuite.addTest(test_bayes.suite())
+- testsuite.addTest(test_scripts.suite())
++ # testsuite.addTest(test_scripts.suite())
+ testsuite.addTest(test_spline.suite())
+ testsuite.addTest(test_sparse_builder.suite())
+ testsuite.addTest(test_goniometer.suite())
diff --git a/debian/patches/0005-Swapped-fvisibility-and-D.patch b/debian/patches/0005-Swapped-fvisibility-and-D.patch
deleted file mode 100644
index b6396b3..0000000
--- a/debian/patches/0005-Swapped-fvisibility-and-D.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Alexandre Marie <alexandre.marie@synchrotron-soleil.fr>
-Date: Tue, 8 Jan 2019 11:08:44 +0100
-Subject: Swapped -fvisibility and -D.
-
----
- setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index 74eb6f0..029addb 100644
---- a/setup.py
-+++ b/setup.py
-@@ -650,7 +650,7 @@ class BuildExt(build_ext):
- return_type = 'void' if sys.version_info[0] <= 2 else 'PyObject*'
-
- ext.extra_compile_args.append(
-- '''-fvisibility=hidden -D'PyMODINIT_FUNC=%s__attribute__((visibility("default"))) %s ' ''' % (extern, return_type))
-+ '''-D'PyMODINIT_FUNC=%s__attribute__((visibility("default"))) %s ' -fvisibility=hidden''' % (extern, return_type))
-
- def is_debug_interpreter(self):
- """
diff --git a/debian/patches/0005-fix-the-setup-dependencies.patch b/debian/patches/0005-fix-the-setup-dependencies.patch
index 1beaff5..375fe45 100644
--- a/debian/patches/0005-fix-the-setup-dependencies.patch
+++ b/debian/patches/0005-fix-the-setup-dependencies.patch
@@ -4,31 +4,17 @@ Date: Mon, 4 Sep 2017 14:12:04 +0200
Subject: fix the setup dependencies
---
- setup.py | 17 ++++++++---------
- 1 file changed, 8 insertions(+), 9 deletions(-)
+ setup.py | 12 +++++++++---
+ 1 file changed, 9 insertions(+), 3 deletions(-)
diff --git a/setup.py b/setup.py
-index 8d742c1..74eb6f0 100644
+index f711f91..79c56b0 100644
--- a/setup.py
+++ b/setup.py
-@@ -261,7 +261,7 @@ class BuildMan(Command):
-
- def get_synopsis(self, module_name, env, log_output=False):
- """Execute a script to retrieve the synopsis for help2man
-- :return: synopsis
-+ :return: synopsis
- :rtype: single line string
- """
- import subprocess
-@@ -934,19 +934,18 @@ def get_project_configuration(dry_run):
- """Returns project arguments for setup"""
-
- install_requires = [
-- "numpy",
-- # h5py was removed from dependencies cause it creates an issue with
-- # Debian 8. Pip is not aware that h5py is installed and pkg_resources
-- # check dependencies and in this case raise an exception
-- # FIXME we still have to investigate
+@@ -967,14 +967,20 @@ def get_project_configuration(dry_run):
+ # Debian 8. Pip is not aware that h5py is installed and pkg_resources
+ # check dependencies and in this case raise an exception
+ # FIXME we still have to investigate
- # "h5py",
"fabio",
+ "h5py",
@@ -36,14 +22,16 @@ index 8d742c1..74eb6f0 100644
- "scipy",
"numexpr",
+ "numpy",
++ "PyMca5",
+ "pyopencl",
+ "PyQt5",
# for the use of pkg_resources on script launcher
"setuptools",
-- "silx>=0.8"]
+- "silx>=0.10"]
+ "scipy",
-+ "silx>=0.8",
-+ "six"]
++ "silx>=0.10",
++ "six"
++ ]
setup_requires = [
"setuptools",
diff --git a/debian/patches/0006-Hid-ext-args-to-try-to-fix-FTBFS.patch b/debian/patches/0006-Hid-ext-args-to-try-to-fix-FTBFS.patch
deleted file mode 100644
index 33ff6d9..0000000
--- a/debian/patches/0006-Hid-ext-args-to-try-to-fix-FTBFS.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From: Alexandre Marie <alexandre.marie@synchrotron-soleil.fr>
-Date: Tue, 8 Jan 2019 11:37:44 +0100
-Subject: Hid ext args to try to fix FTBFS
-
----
- setup.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index 029addb..781c1c1 100644
---- a/setup.py
-+++ b/setup.py
-@@ -649,8 +649,8 @@ class BuildExt(build_ext):
- extern = 'extern "C" ' if ext.language == 'c++' else ''
- return_type = 'void' if sys.version_info[0] <= 2 else 'PyObject*'
-
-- ext.extra_compile_args.append(
-- '''-D'PyMODINIT_FUNC=%s__attribute__((visibility("default"))) %s ' -fvisibility=hidden''' % (extern, return_type))
-+ # ext.extra_compile_args.append(
-+ # '''-D'PyMODINIT_FUNC=%s__attribute__((visibility("default"))) %s ' -fvisibility=hidden''' % (extern, return_type))
-
- def is_debug_interpreter(self):
- """
diff --git a/debian/patches/series b/debian/patches/series
index 359b203..05c8f9f 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,6 +1,4 @@
0003-use-the-system-mathjax.patch
0003-remove-a-wrong-PYTHONPATH-modification.patch
0005-fix-the-setup-dependencies.patch
-0004-Skipped-unittests-for-i386-arch.patch
-0005-Swapped-fvisibility-and-D.patch
-0006-Hid-ext-args-to-try-to-fix-FTBFS.patch
+0004-unactive-script-test.patch