summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2023-07-24 11:40:48 +0200
committerPicca Frédéric-Emmanuel <picca@debian.org>2023-07-24 11:40:48 +0200
commit36874cf739fb37ae2115c63f1a51459c3313dc68 (patch)
tree4de76c75213dab151f79ffa98fcfb260b1513f18
parent1a3e8d5d37befd8ee2e4eb1555796905e4c1be66 (diff)
run OpenCL tets only on amd64 arm64 armhf
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules2
-rw-r--r--debian/tests/control24
3 files changed, 26 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index ca16128..50c1203 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
pyfai (2023.5.0+dfsg1-6) UNRELEASED; urgency=medium
* Set upstream metadata fields: Security-Contact.
+ * d/control: remove the OpenCL test for i386
+ * d/t/control: created a dedicated flaky test for OpenCL test.
-- Picca Frédéric-Emmanuel <picca@debian.org> Fri, 21 Jul 2023 13:30:42 -0000
diff --git a/debian/rules b/debian/rules
index 236d70a..1b10b9b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,7 +7,7 @@ export PYBUILD_NAME=pyfai
export PYOPENCL_COMPILER_OUTPUT=1
# run OpenCL tests on a selected set of architecture
-ifneq (,$(filter $(DEB_BUILD_ARCH),amd64 arm64 armhf i386))
+ifneq (,$(filter $(DEB_BUILD_ARCH),amd64 arm64 armhf))
export PYFAI_OPENCL=True
else
export PYFAI_OPENCL=False
diff --git a/debian/tests/control b/debian/tests/control
index bb430c7..af01593 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -1,16 +1,38 @@
Test-Command: set -efu
+ ; export PYFAI_OPENCL=False
; cp bootstrap.py run_tests.py pyproject.toml version.py README.rst "$AUTOPKGTEST_TMP"
; for py in $(py3versions -r 2>/dev/null)
; do cd "$AUTOPKGTEST_TMP"
; echo "Testing with $py:"
; xvfb-run -a --server-args="-screen 0 1024x768x24" $py run_tests.py -v -m --installed
; done
+Architecture: !amd64 !arm64 !armhf
Depends:
bitshuffle,
- pocl-opencl-icd [amd64 arm64 armhf i386],
python3-all,
python3-pyfai,
python3-tk,
xauth,
xvfb,
Restrictions: allow-stderr, skip-not-installable
+
+# Check that OpenCL isn't totally broken (note that it isn't totally working either)
+# Uses device 0 platform 0, i.e. to use a real GPU manually install its opencl-icd before running this
+# Mark the test has flaky, the important part is the CPU computation.
+Test-Command:set -efu
+ ; export PYFAI_OPENCL=True
+ ; cp bootstrap.py run_tests.py pyproject.toml version.py README.rst "$AUTOPKGTEST_TMP"
+ ; for py in $(py3versions -r 2>/dev/null)
+ ; do cd "$AUTOPKGTEST_TMP"
+ ; echo "Testing with $py:"
+ ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py run_tests.py -v -m --installed
+ ; done
+Depends:
+ bitshuffle,
+ pocl-opencl-icd,
+ python3-all,
+ python3-pyfai,
+ python3-tk,
+ xauth,
+ xvfb,
+Restrictions: allow-stderr, skip-not-installable, flaky