summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini19
1 files changed, 19 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..4cf1eb6
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,19 @@
+[tox]
+envlist = check,py37
+
+[testenv]
+setenv =
+ PYTHONPATH={toxinidir}/tests
+ PYTHONUNBUFFERED=yes
+deps =
+ pytest
+ coveralls
+ pytest-cov
+commands = {posargs:pytest -vv --cov=pyfavicon tests}
+
+[testenv:check]
+deps =
+ flake8
+skip_install = true
+commands =
+ flake8 --ignore=E501 pyfavicon tests examples setup.py