summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohan Fleury <jfleury@arcaik.net>2018-10-08 12:58:12 -0400
committerJohan Fleury <jfleury@arcaik.net>2018-10-08 12:58:12 -0400
commit735c78d3ecb695dd16cb37879880f522c4b29c72 (patch)
tree8bfb2ecbd0f03730efa1540cc65d8490b67e8ddd /Makefile
Import upstream version 1.7.0
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..2a76f88
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,47 @@
+help:
+ @echo "Please use 'make <target>' where <target> is one of"
+ @echo " clean remove temporary files created by build tools"
+ @echo " cleanegg remove temporary files created by build tools"
+ @echo " cleanpy remove temporary python files"
+ @echo " cleancov remove files used and generated by coverage tools"
+ @echo " cleanall all the above + tmp files from development tools (Not cleantox)"
+ @echo " cleantox remove files created by tox"
+ @echo " test run test suite"
+ @echo " sdist make a source distribution"
+ @echo " install install package"
+
+clean:
+ -rm -f MANIFEST
+ -rm -rf dist/
+ -rm -rf build/
+
+cleantox:
+ -rm -rf .tox/
+
+cleancov:
+ coverage combine
+ coverage erase
+ -rm -rf htmlcov/
+
+cleanegg:
+ -rm -rf pykwalify.egg-info/
+
+cleanpy:
+ -find . -type f -name "*~" -exec rm -f "{}" \;
+ -find . -type f -name "*.orig" -exec rm -f "{}" \;
+ -find . -type f -name "*.rej" -exec rm -f "{}" \;
+ -find . -type f -name "*.pyc" -exec rm -f "{}" \;
+ -find . -type f -name "*.parse-index" -exec rm -f "{}" \;
+ -find . -type d -name "__pycache__" -exec rm -rf "{}" \;
+
+cleanall: clean cleanegg cleanpy cleancov
+
+test:
+ coverage erase
+ coverage run --source pykwalify/ -m python py.test
+
+sdist:
+ python setup.py sdist
+
+install:
+ python setup.py install