summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Stender <debian@danielstender.com>2015-07-26 22:49:30 +0200
committerDaniel Stender <debian@danielstender.com>2015-07-26 22:51:03 +0200
commit5228cb84daa2a5e4c44bebe8500d6f4e545d7b19 (patch)
tree6990b789e04a1f2cb26eb93c748a3ae96922d1da
parent9f7b3008a9ac46b7780bbc50629e207b4ca365e9 (diff)
Imported Debian patch 1.1-1
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control56
-rw-r--r--debian/copyright33
-rw-r--r--debian/gbp.conf8
-rwxr-xr-xdebian/rules17
-rw-r--r--debian/source/format1
-rw-r--r--debian/source/options1
-rw-r--r--debian/tests/control7
-rwxr-xr-xdebian/tests/python-pytest-catchlog2
-rwxr-xr-xdebian/tests/python3-pytest-catchlog2
-rw-r--r--debian/watch3
12 files changed, 136 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..086186a
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+pytest-catchlog (1.1-1) UNRELEASED; urgency=medium
+
+ * Initial release (Closes: #793191)
+
+ -- Daniel Stender <debian@danielstender.com> Sun, 26 Jul 2015 22:49:30 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..5cf220c
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,56 @@
+Source: pytest-catchlog
+Section: python
+Priority: optional
+Maintainer: Daniel Stender <debian@danielstender.com>
+Uploaders:
+ Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
+Build-Depends:
+ debhelper (>= 9),
+ dh-python,
+ python-all,
+ python-py,
+ python-setuptools,
+ python-pytest,
+ python3-all,
+ python3-py,
+ python3-setuptools,
+ python3-pytest
+Standards-Version: 3.9.6
+Homepage: https://github.com/eisensheng/pytest-catchlog
+Vcs-Git: git://anonscm.debian.org/python-modules/packages/pytest-catchlog.git
+Vcs-Browser: http://anonscm.debian.org/cgit/python-modules/packages/pytest-catchlog.git
+X-Python-Version: >= 2.6
+X-Python3-Version: >= 3.2
+Testsuite: autopkgtest
+
+Package: python-pytest-catchlog
+Architecture: all
+Depends:
+ python-pytest,
+ ${misc:Depends},
+ ${python:Depends}
+Description: py.test plugin to capture test log messages
+ By default each captured log message shows the module, line number, log level
+ and message. Showing the exact module and line number is useful for testing
+ and debugging. If desired the log format and date format can be specified to
+ anything that the logging module supports.
+ .
+ This is a fork of pytest-capturelog by Meme Dough.
+ .
+ The package contains the plugin for Python 2 code.
+
+Package: python3-pytest-catchlog
+Architecture: all
+Depends:
+ python3-pytest,
+ ${misc:Depends},
+ ${python3:Depends}
+Description: py.test plugin to capture test log messages (Python3)
+ By default each captured log message shows the module, line number, log level
+ and message. Showing the exact module and line number is useful for testing
+ and debugging. If desired the log format and date format can be specified to
+ anything that the logging module supports.
+ .
+ This is a fork of pytest-capturelog by Meme Dough.
+ .
+ The package contains the plugin for Python 3 code.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..481a554
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,33 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: pytest-catchlog
+Upstream-Contact: Arthur Skowronek <eisensheng@mailbox.org>
+Source: https://github.com/eisensheng/pytest-catchlog
+
+Files: *
+Copyright: 2010 Meme Dough <memedough@gmail.com>
+ 2014-2015 Arthur Skowronek
+License: Expat
+
+Files: debian/*
+Copyright: 2015 Daniel Stender <debian@danielstender.com>
+License: Expat
+
+License: Expat
+ Permission is hereby granted, free of charge, to any person obtaining a
+ copy of this software and associated documentation files (the
+ "Software"), to deal in the Software without restriction, including
+ without limitation the rights to use, copy, modify, merge, publish,
+ distribute, sublicense, and/or sell copies of the Software, and to
+ permit persons to whom the Software is furnished to do so, subject to
+ the following conditions:
+ .
+ The above copyright notice and this permission notice shall be included
+ in all copies or substantial portions of the Software.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND EXPRESS
+ OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+ IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+ CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+ TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 0000000..78ab127
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,8 @@
+[DEFAULT]
+upstream-tag = upstream/%(version)s
+debian-tag = debian/%(version)s
+pristine-tar = True
+
+[import-orig]
+upstream-branch = upstream
+debian-branch = master
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ba010d6
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+#export DH_VERBOSE=1
+#export DEB_BUILD_OPTIONS=nocheck
+export PYBUILD_NAME=pytest-catchlog
+
+%:
+ dh $@ --with python2,python3 --buildsystem=pybuild
+
+override_dh_auto_test:
+
+override_dh_auto_install:
+ dh_auto_install
+ PYBUILD_SYSTEM=custom PYBUILD_TEST_ARGS="{interpreter} -m pytest -v -x" dh_auto_test
+ # run tests after install bcs the plugin needs to get registered by setup.py/entry_points
+
+override_dh_installdocs:
+ dh_installdocs -A README.rst
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/source/options b/debian/source/options
new file mode 100644
index 0000000..6e88e49
--- /dev/null
+++ b/debian/source/options
@@ -0,0 +1 @@
+extend-diff-ignore="^[^/]+\.egg-info/" \ No newline at end of file
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 0000000..3939442
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,7 @@
+Tests: python-pytest-catchlog
+Depends: @, python-all, python-pytest, python-py
+Restrictions: allow-stderr
+
+Tests: python3-pytest-catchlog
+Depends: @, python3-all, python3-pytest, python3-py
+Restrictions: allow-stderr
diff --git a/debian/tests/python-pytest-catchlog b/debian/tests/python-pytest-catchlog
new file mode 100755
index 0000000..6cd9308
--- /dev/null
+++ b/debian/tests/python-pytest-catchlog
@@ -0,0 +1,2 @@
+#!/bin/sh -e
+pyversions -i | tr ' ' '\n' | xargs -I {} env {} -Wd -m pytest -v -x
diff --git a/debian/tests/python3-pytest-catchlog b/debian/tests/python3-pytest-catchlog
new file mode 100755
index 0000000..b4271db
--- /dev/null
+++ b/debian/tests/python3-pytest-catchlog
@@ -0,0 +1,2 @@
+#!/bin/sh -e
+py3versions -i | tr ' ' '\n' | xargs -I {} env {} -Wd -m pytest -v -x
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..1642471
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,3 @@
+version=3
+opts="filenamemangle=s/(?:.*\/)?v?(\d[\d\.]+)\.tar\.gz/pytest-catchlog-$1.tar.gz/" \
+https://github.com/eisensheng/pytest-catchlog/releases (?:.*/)?v?(\d[\d\.]+)\.tar\.gz