summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index ba84092..0a99448 100755
--- a/setup.py
+++ b/setup.py
@@ -21,26 +21,29 @@ setup(name='pytest-catchlog',
version=_get_version(),
description=('py.test plugin to catch log messages.'
' This is a fork of pytest-capturelog.'),
- long_description=_read_text_file('README.rst'),
+ long_description='\n'.join([_read_text_file('README.rst'),
+ _read_text_file('CHANGES.rst'), ]),
author='Arthur Skowronek (Fork Author)', # original author: Meme Dough
author_email='eisensheng@mailbox.org',
url='https://github.com/eisensheng/pytest-catchlog',
py_modules=['pytest_catchlog', ],
- install_requires=['py>=1.1.1', ],
+ install_requires=['py>=1.1.1', 'pytest>=2.6'],
entry_points={'pytest11': ['pytest_catchlog = pytest_catchlog']},
license='MIT License',
zip_safe=False,
- keywords='py.test pytest',
+ keywords='py.test pytest logging',
classifiers=['Development Status :: 4 - Beta',
'Intended Audience :: Developers',
'License :: OSI Approved :: MIT License',
'Operating System :: OS Independent',
'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Software Development :: Testing'])