summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelipe Sateler <fsateler@debian.org>2017-07-16 11:34:24 -0400
committerFelipe Sateler <fsateler@debian.org>2017-11-05 11:00:09 -0300
commit07868a5fb88d68a485f36996dca4579c8514fa1d (patch)
tree50d6e6ba5c401df2630fa590456706adec3d4373
parent926b85b8326e6cf4f8729cd9225f0dd6411c9f0a (diff)
Do not require pip for building
It is only used to check for docker-py existece, but that doesn't matter in the context of a debian build Gbp-Pq: Name Do-not-require-pip-for-building.patch
-rw-r--r--setup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 4a33c8d..e8f13ee 100644
--- a/setup.py
+++ b/setup.py
@@ -5,17 +5,8 @@ import codecs
import os
import sys
-import pip
-
from setuptools import setup, find_packages
-if 'docker-py' in [x.project_name for x in pip.get_installed_distributions()]:
- print(
- 'ERROR: "docker-py" needs to be uninstalled before installing this'
- ' package:\npip uninstall docker-py', file=sys.stderr
- )
- sys.exit(1)
-
ROOT_DIR = os.path.dirname(__file__)
SOURCE_DIR = os.path.join(ROOT_DIR)