summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSandro Tosi <morph@debian.org>2019-10-19 17:48:18 -0400
committerFelipe Sateler <fsateler@debian.org>2019-11-22 20:50:24 -0300
commit0e08ec700f3e27bee8da6605cdd93491a14454dd (patch)
treeeb9ce2bdd448d7469348bffe1ca1a038593fc9da
parent2db366a7cd40e5019776fc3a07216d7e03a5dae8 (diff)
Import Debian changes 3.4.1-4.1
python-docker (3.4.1-4.1) unstable; urgency=medium * Non-maintainer upload. * Drop python2 support; Closes: #937714
-rw-r--r--debian/changelog7
-rw-r--r--debian/control24
-rwxr-xr-xdebian/rules2
-rw-r--r--debian/tests/control2
-rwxr-xr-xdebian/tests/integration1
5 files changed, 9 insertions, 27 deletions
diff --git a/debian/changelog b/debian/changelog
index 6686d66..915b183 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+python-docker (3.4.1-4.1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Drop python2 support; Closes: #937714
+
+ -- Sandro Tosi <morph@debian.org> Sat, 19 Oct 2019 17:48:18 -0400
+
python-docker (3.4.1-4) unstable; urgency=medium
* Revert "Drop dependency on ssl-match-hostname backport"
diff --git a/debian/control b/debian/control
index 54d92ba..28613a6 100644
--- a/debian/control
+++ b/debian/control
@@ -6,17 +6,8 @@ Uploaders: Jason Pleau <jason@jpleau.ca>,
Felipe Sateler <fsateler@debian.org>
Build-Depends: debhelper (>= 10),
dh-python,
- python-all (>= 2.7),
python3-all,
- python-setuptools,
python3-setuptools,
-# setup.py
- python-requests (>= 2.11.1~),
- python-six (>= 1.4.0~),
- python-websocket (>= 0.32.0~),
- python-dockerpycreds (>= 0.2.2),
- python-backports.ssl-match-hostname (>= 3.5),
- python-ipaddress (>=1.0.16),
# setup.py - python3
python3-requests (>= 2.11.1~),
python3-six (>= 1.4.0~),
@@ -32,21 +23,6 @@ Vcs-Git: https://salsa.debian.org/docker-compose-team/python-docker
Vcs-Browser: https://salsa.debian.org/docker-compose-team/python-docker
X-Python3-Version: >= 3.5
-Package: python-docker
-Architecture: all
-Depends: ${misc:Depends}, ${python:Depends},
- python-backports.ssl-match-hostname (>= 3.5),
- python-ipaddress (>=1.0.16)
-Breaks: python-magnum (<< 5.0.0),
- python-senlin (<< 2.0.0),
- docker-compose (<< 1.21)
-Description: Python wrapper to access docker.io's control socket
- This package contains oodles of routines that aid in controlling
- docker.io over it's socket control, the same way the docker.io
- client controls the daemon.
- .
- This package provides Python 2 module bindings only.
-
Package: python3-docker
Architecture: all
Depends: ${misc:Depends}, ${python3:Depends}
diff --git a/debian/rules b/debian/rules
index 91e153c..9ffd4ee 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,4 +10,4 @@ override_dh_auto_clean:
rm -f docker_py.egg-info/SOURCES.txt
%:
- dh $@ --with python2,python3 --buildsystem pybuild
+ dh $@ --with python3 --buildsystem pybuild
diff --git a/debian/tests/control b/debian/tests/control
index 3b02db1..6163e1b 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -1,3 +1,3 @@
Tests: integration
-Depends: docker.io, python-mock, python-pytest, python3-mock, python3-pytest, python-backports.ssl-match-hostname, @
+Depends: docker.io, python3-mock, python3-pytest, @
Restrictions: isolation-machine needs-root
diff --git a/debian/tests/integration b/debian/tests/integration
index 156b4e7..2012a95 100755
--- a/debian/tests/integration
+++ b/debian/tests/integration
@@ -2,4 +2,3 @@
set -e
py.test-3 tests/integration/
-py.test tests/integration/