summaryrefslogtreecommitdiff
path: root/debian/Dockerfile
diff options
context:
space:
mode:
authorTianon Gravi <admwiggin@gmail.com>2014-05-05 22:09:25 +0000
committerTianon Gravi <admwiggin@gmail.com>2014-05-05 22:09:25 +0000
commitdd598c7ba18844ed4c1068e3b85a248720980e8c (patch)
treed9c2869dbd260fd924d41b01621931e1980c1240 /debian/Dockerfile
parentf9b39a30f26fc6892a03e077c4ff4aa8074a3930 (diff)
Bump upstream version and Standards-Version, add myself to Uploaders explicitly, and note specifically what's currently holding back python3-docker
Diffstat (limited to 'debian/Dockerfile')
-rw-r--r--debian/Dockerfile20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/Dockerfile b/debian/Dockerfile
new file mode 100644
index 0000000..fc46bd0
--- /dev/null
+++ b/debian/Dockerfile
@@ -0,0 +1,20 @@
+FROM tianon/debian-devel
+
+# start by adding just "debian/control" so we can get mk-build-deps with maximum caching
+ADD control /usr/src/python-docker/debian/
+WORKDIR /usr/src/python-docker
+
+# get all the build deps of _this_ package in a nice repeatable way
+RUN apt-get update && mk-build-deps -irt'apt-get --no-install-recommends -yq' debian/control
+
+# need our debian/ directory to compile _this_ package
+ADD . /usr/src/python-docker/debian
+
+# go download and unpack our upstream source
+RUN uscan --force-download --verbose --download-current-version
+RUN origtargz --unpack
+
+# tianon is _really_ lazy, and likes a preseeded bash history
+RUN echo 'origtargz --unpack && debuild -us -uc --lintian-opts "-EvIL+pedantic"' >> "$HOME/.bash_history"
+
+CMD [ "debuild", "-us", "-uc", "--lintian-opts", "-EvIL+pedantic" ]