summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorTianon Gravi <admwiggin@gmail.com>2014-07-10 14:19:34 +0000
committerTianon Gravi <admwiggin@gmail.com>2014-07-10 14:19:34 +0000
commit2aa097bbefca813e23958c7d7e5d0f47d9681c72 (patch)
tree6cb1b325e5018ab3941d889b92e4aa8c3ba8de9a /debian/rules
parent53b86aad1a8fffe87c7e4685ff05d3b0fca3c8a0 (diff)
Switch to pybuild and add python3-docker
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules42
1 files changed, 5 insertions, 37 deletions
diff --git a/debian/rules b/debian/rules
index b3a8e2d..b180c5f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,42 +1,10 @@
#!/usr/bin/make -f
-PY2_PACKAGE_NAME=python-docker
-#PY3_PACKAGE_NAME=python3-docker
+export PYBUILD_NAME=docker
-PYVERS = $(shell pyversions -r)
-#PY3VERS = $(shell py3versions -r)
+# The tests fail with the cryptic "ImportError: No module named tests".
+# I don't have the time or the energy to debug them (especially since it looks like there aren't many).
+export PYBUILD_DISABLE=test
%:
- dh $@ --with python2 # ,python3
-
-override_dh_auto_clean:
- dh_auto_clean
- rm -rvf ./docs/build ./*.egg-info ./build
-
-override_dh_auto_build:
- set -xe; \
- #for py in $(PYVERS) $(PY3VERS); do \
- # $$py setup.py build; \
- #done
- # XXX: Remove under me once we enable py3
- for py in $(PYVERS); do \
- $$py setup.py build; \
- done
-
-override_dh_auto_install:
- set -xe; \
- for py in $(PYVERS); do \
- $$py setup.py install --skip-build --root debian/$(PY2_PACKAGE_NAME) \
- --install-layout deb; \
- done
- #set -xe; \
- # for py in $(PY3VERS); do \
- # $$py setup.py install --skip-build --root debian/$(PY3_PACKAGE_NAME) \
- # --install-layout deb; \
- #done
- # Remove me when dh_python2 can handle this file
- rm -vf debian/*/usr/lib/python*/*-packages/*.egg-info/SOURCES.txt
-
-override_dh_installchangelogs:
- # The bundle on pypi doesn't include the ChangeLog.md file :(
- dh_installchangelogs # ChangeLog.md
+ dh $@ --with python2,python3 --buildsystem pybuild