summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorPaul Richards Tagliamonte <paultag@debian.org>2014-02-11 03:23:53 +0000
committerPaul Richards Tagliamonte <paultag@debian.org>2014-02-11 03:23:53 +0000
commit78547df6164b9a577cdd06369cc96c9a7e5bcf19 (patch)
treeb90db4772ff2983a88321a9970f095bca1b542d6 /debian/rules
[svn-inject] Applying Debian modifications (0.2.3-1) to trunk
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules34
1 files changed, 34 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..fd0cc7e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,34 @@
+#!/usr/bin/make -f
+
+PY2_PACKAGE_NAME=python-docker
+PY3_PACKAGE_NAME=python3-docker
+
+PYVERS = $(shell pyversions -r)
+PY3VERS = $(shell py3versions -r)
+
+%:
+ dh $@ --with python2,python3
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -rvf ./docs/build ./*.egg-info ./build
+
+override_dh_auto_build:
+ set -xe; \
+ for py in $(PYVERS) $(PY3VERS); do \
+ $$py setup.py build; \
+ done
+
+override_dh_auto_install:
+ set -xe; \
+ for py in $(PYVERS); do \
+ $$py setup.py install --skip-build --root debian/$(PY2_PACKAGE_NAME) \
+ --install-layout deb; \
+ done
+ set -xe; \
+ for py in $(PY3VERS); do \
+ $$py setup.py install --skip-build --root debian/$(PY3_PACKAGE_NAME) \
+ --install-layout deb; \
+ done
+ # Remove me when dh_python2 can handle this file
+ rm -vf debian/*/usr/lib/python*/*-packages/*.egg-info/SOURCES.txt