summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorTianon Gravi <tianon@debian.org>2015-11-08 10:59:34 -0800
committerTianon Gravi <tianon@debian.org>2015-11-08 10:59:34 -0800
commitdda3364929e37f8749f58dfc92013bc442f76fb5 (patch)
treec3b3267862d9312af959ad1d83e3e136e3f7ad78 /debian/rules
parent4c2af449a2408cdf410e446ca96248578d39e5a2 (diff)
Add SOURCES.txt removal to "clean" to clean up after ourselves
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index d93c067..91e153c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,5 +5,9 @@ export PYBUILD_NAME=docker
# The pypi bundle includes the tests (https://github.com/docker/docker-py/issues/308), but they're really invasive and fail for reasons I haven't yet diagnosed.
export PYBUILD_DISABLE=test
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -f docker_py.egg-info/SOURCES.txt
+
%:
dh $@ --with python2,python3 --buildsystem pybuild