summaryrefslogtreecommitdiff
path: root/docker.egg-info
diff options
context:
space:
mode:
Diffstat (limited to 'docker.egg-info')
-rw-r--r--docker.egg-info/PKG-INFO125
-rw-r--r--docker.egg-info/SOURCES.txt16
-rw-r--r--docker.egg-info/requires.txt10
3 files changed, 79 insertions, 72 deletions
diff --git a/docker.egg-info/PKG-INFO b/docker.egg-info/PKG-INFO
index d8c4409..8754725 100644
--- a/docker.egg-info/PKG-INFO
+++ b/docker.egg-info/PKG-INFO
@@ -1,105 +1,92 @@
-Metadata-Version: 1.1
+Metadata-Version: 2.1
Name: docker
-Version: 3.4.1
+Version: 4.1.0
Summary: A Python library for the Docker Engine API.
Home-page: https://github.com/docker/docker-py
-Author: Joffrey F
-Author-email: joffrey@docker.com
+Maintainer: Joffrey F
+Maintainer-email: joffrey@docker.com
License: Apache License 2.0
-Description: Docker SDK for Python
- =====================
+Project-URL: Source, https://github.com/docker/docker-py
+Project-URL: Documentation, https://docker-py.readthedocs.io
+Project-URL: Tracker, https://github.com/docker/docker-py/issues
+Project-URL: Changelog, https://docker-py.readthedocs.io/en/stable/change-log.html
+Description: # Docker SDK for Python
- |Build Status|
+ [![Build Status](https://travis-ci.org/docker/docker-py.svg?branch=master)](https://travis-ci.org/docker/docker-py)
- A Python library for the Docker Engine API. It lets you do anything the
- ``docker`` command does, but from within Python apps – run containers,
- manage containers, manage Swarms, etc.
+ A Python library for the Docker Engine API. It lets you do anything the `docker` command does, but from within Python apps – run containers, manage containers, manage Swarms, etc.
- Installation
- ------------
+ ## Installation
- The latest stable version `is available on
- PyPI <https://pypi.python.org/pypi/docker/>`__. Either add ``docker`` to
- your ``requirements.txt`` file or install with pip:
-
- ::
+ The latest stable version [is available on PyPI](https://pypi.python.org/pypi/docker/). Either add `docker` to your `requirements.txt` file or install with pip:
pip install docker
- If you are intending to connect to a docker host via TLS, add
- ``docker[tls]`` to your requirements instead, or install with pip:
-
- ::
+ If you are intending to connect to a docker host via TLS, add `docker[tls]` to your requirements instead, or install with pip:
pip install docker[tls]
- Usage
- -----
-
- Connect to Docker using the default socket or the configuration in your
- environment:
+ ## Usage
- .. code:: python
+ Connect to Docker using the default socket or the configuration in your environment:
- import docker
- client = docker.from_env()
+ ```python
+ import docker
+ client = docker.from_env()
+ ```
You can run containers:
- .. code:: python
-
- >>> client.containers.run("ubuntu:latest", "echo hello world")
- 'hello world\n'
+ ```python
+ >>> client.containers.run("ubuntu:latest", "echo hello world")
+ 'hello world\n'
+ ```
You can run containers in the background:
- .. code:: python
-
- >>> client.containers.run("bfirsh/reticulate-splines", detach=True)
- <Container '45e6d2de7c54'>
+ ```python
+ >>> client.containers.run("bfirsh/reticulate-splines", detach=True)
+ <Container '45e6d2de7c54'>
+ ```
You can manage containers:
- .. code:: python
+ ```python
+ >>> client.containers.list()
+ [<Container '45e6d2de7c54'>, <Container 'db18e4f20eaa'>, ...]
- >>> client.containers.list()
- [<Container '45e6d2de7c54'>, <Container 'db18e4f20eaa'>, ...]
+ >>> container = client.containers.get('45e6d2de7c54')
- >>> container = client.containers.get('45e6d2de7c54')
+ >>> container.attrs['Config']['Image']
+ "bfirsh/reticulate-splines"
- >>> container.attrs['Config']['Image']
- "bfirsh/reticulate-splines"
+ >>> container.logs()
+ "Reticulating spline 1...\n"
- >>> container.logs()
- "Reticulating spline 1...\n"
-
- >>> container.stop()
+ >>> container.stop()
+ ```
You can stream logs:
- .. code:: python
-
- >>> for line in container.logs(stream=True):
- ... print line.strip()
- Reticulating spline 2...
- Reticulating spline 3...
- ...
+ ```python
+ >>> for line in container.logs(stream=True):
+ ... print line.strip()
+ Reticulating spline 2...
+ Reticulating spline 3...
+ ...
+ ```
You can manage images:
- .. code:: python
-
- >>> client.images.pull('nginx')
- <Image 'nginx'>
-
- >>> client.images.list()
- [<Image 'ubuntu'>, <Image 'nginx'>, ...]
+ ```python
+ >>> client.images.pull('nginx')
+ <Image 'nginx'>
- `Read the full documentation <https://docker-py.readthedocs.io>`__ to
- see everything you can do.
+ >>> client.images.list()
+ [<Image 'ubuntu'>, <Image 'nginx'>, ...]
+ ```
- .. |Build Status| image:: https://travis-ci.org/docker/docker-py.svg?branch=master
- :target: https://travis-ci.org/docker/docker-py
+ [Read the full documentation](https://docker-py.readthedocs.io) to see everything you can do.
Platform: UNKNOWN
Classifier: Development Status :: 5 - Production/Stable
@@ -110,9 +97,13 @@ Classifier: Programming Language :: Python
Classifier: Programming Language :: Python :: 2
Classifier: Programming Language :: Python :: 2.7
Classifier: Programming Language :: Python :: 3
-Classifier: Programming Language :: Python :: 3.3
-Classifier: Programming Language :: Python :: 3.4
Classifier: Programming Language :: Python :: 3.5
Classifier: Programming Language :: Python :: 3.6
+Classifier: Programming Language :: Python :: 3.7
+Classifier: Topic :: Software Development
Classifier: Topic :: Utilities
Classifier: License :: OSI Approved :: Apache Software License
+Requires-Python: >=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*
+Description-Content-Type: text/markdown
+Provides-Extra: tls
+Provides-Extra: ssh
diff --git a/docker.egg-info/SOURCES.txt b/docker.egg-info/SOURCES.txt
index 02d2f19..6daee4c 100644
--- a/docker.egg-info/SOURCES.txt
+++ b/docker.egg-info/SOURCES.txt
@@ -1,7 +1,6 @@
LICENSE
MANIFEST.in
README.md
-README.rst
requirements.txt
setup.cfg
setup.py
@@ -33,6 +32,11 @@ docker/api/secret.py
docker/api/service.py
docker/api/swarm.py
docker/api/volume.py
+docker/credentials/__init__.py
+docker/credentials/constants.py
+docker/credentials/errors.py
+docker/credentials/store.py
+docker/credentials/utils.py
docker/models/__init__.py
docker/models/configs.py
docker/models/containers.py
@@ -46,8 +50,10 @@ docker/models/services.py
docker/models/swarm.py
docker/models/volumes.py
docker/transport/__init__.py
+docker/transport/basehttpadapter.py
docker/transport/npipeconn.py
docker/transport/npipesocket.py
+docker/transport/sshconn.py
docker/transport/ssladapter.py
docker/transport/unixconn.py
docker/types/__init__.py
@@ -65,10 +71,13 @@ docker/utils/decorators.py
docker/utils/fnmatch.py
docker/utils/json_stream.py
docker/utils/ports.py
+docker/utils/proxy.py
docker/utils/socket.py
docker/utils/utils.py
tests/__init__.py
tests/helpers.py
+tests/gpg-keys/ownertrust
+tests/gpg-keys/secret
tests/integration/__init__.py
tests/integration/api_build_test.py
tests/integration/api_client_test.py
@@ -96,6 +105,9 @@ tests/integration/models_services_test.py
tests/integration/models_swarm_test.py
tests/integration/models_volumes_test.py
tests/integration/regression_test.py
+tests/integration/credentials/__init__.py
+tests/integration/credentials/store_test.py
+tests/integration/credentials/utils_test.py
tests/integration/testdata/dummy-plugin/config.json
tests/integration/testdata/dummy-plugin/rootfs/dummy/file.txt
tests/unit/__init__.py
@@ -120,9 +132,11 @@ tests/unit/models_resources_test.py
tests/unit/models_services_test.py
tests/unit/ssladapter_test.py
tests/unit/swarm_test.py
+tests/unit/types_containers_test.py
tests/unit/utils_build_test.py
tests/unit/utils_config_test.py
tests/unit/utils_json_stream_test.py
+tests/unit/utils_proxy_test.py
tests/unit/utils_test.py
tests/unit/testdata/certs/ca.pem
tests/unit/testdata/certs/cert.pem
diff --git a/docker.egg-info/requires.txt b/docker.egg-info/requires.txt
index e0b0763..415d2e6 100644
--- a/docker.egg-info/requires.txt
+++ b/docker.egg-info/requires.txt
@@ -1,7 +1,6 @@
-requests!=2.18.0,>=2.14.2
six>=1.4.0
websocket-client>=0.32.0
-docker-pycreds>=0.3.0
+requests!=2.18.0,>=2.14.2
[:python_version < "3.3"]
ipaddress>=1.0.16
@@ -13,9 +12,12 @@ backports.ssl_match_hostname>=3.5
pypiwin32==219
[:sys_platform == "win32" and python_version >= "3.6"]
-pypiwin32==220
+pypiwin32==223
+
+[ssh]
+paramiko>=2.4.2
[tls]
-pyOpenSSL>=0.14
+pyOpenSSL>=17.5.0
cryptography>=1.3.4
idna>=2.0.0