summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2008-05-02 20:32:42 +0000
committerAaron M. Ucko <ucko@debian.org>2008-05-02 20:32:42 +0000
commit8ff5fd602100e7714348e2cdf542a80476ac9f9f (patch)
tree27e4ed3ee88a7768d8e02dc932807a63070b0e53 /debian/rules
parentb7e1bef6c6027afb23ccb59a8745cedc5972bdd0 (diff)
Migrate altogether from CDBS to Debhelper 7.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 14 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 5961fff..e8e27c1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,16 @@
#!/usr/bin/make -f
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/quilt/quilt.make
-DEB_PYTHON_SYSTEM = pysupport
-include /usr/share/cdbs/1/class/python-distutils.mk
+build: patch
+ dh build
+
+clean: unpatch
+ dh clean
+
+install: build
+ dh install
+
+binary-indep: install
+ dh binary-indep
+
+binary: binary-indep