summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2014-08-28 03:24:24 +0000
committerAaron M. Ucko <ucko@debian.org>2014-08-28 03:24:24 +0000
commit2d9548317ff069a1fdeb84131c747ed49f84e068 (patch)
tree34c5b38b987856efa1a514b6991116779369ecf1 /debian
parent07aff6944e748ebff2e3612e62b1a6c59264d35b (diff)
Update for wxPython 3.0. (Closes: #759076.)
* debian/control: Suggest python-wxgtk3.0 over 2.8. * debian/patches/04-wx3.0-compat.patch (new): Make the import dialog and its demo play better with wxPython 3.0.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog9
-rw-r--r--debian/control2
-rw-r--r--debian/patches/04-wx3.0-compat.patch21
-rw-r--r--debian/patches/series1
4 files changed, 31 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index caf63f7..54954a0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,15 @@
python-dsv (1.4.1-3) UNRELEASED; urgency=low
+ [ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
- -- Jakub Wilk <jwilk@debian.org> Sun, 05 May 2013 16:02:31 +0200
+ [ Aaron M. Ucko ]
+ * debian/control:
+ - Suggest python-wxgtk3.0 over 2.8.
+ * debian/patches/04-wx3.0-compat.patch (new): Make the import dialog and
+ its demo play better with wxPython 3.0. (Closes: #759076.)
+
+ -- Aaron M. Ucko <ucko@debian.org> Wed, 27 Aug 2014 23:24:17 -0400
python-dsv (1.4.1-2) unstable; urgency=low
diff --git a/debian/control b/debian/control
index a7ee6ab..f00f634 100644
--- a/debian/control
+++ b/debian/control
@@ -12,7 +12,7 @@ Homepage: http://python-dsv.sourceforge.net/
Package: python-dsv
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}
-Suggests: python-wxgtk2.8
+Suggests: python-wxgtk3.0 | python-wxgtk2.8
Provides: ${python:Provides}
Description: Python module for delimiter-separated-value files
Python-DSV is an alternative to Python's standard csv module, with
diff --git a/debian/patches/04-wx3.0-compat.patch b/debian/patches/04-wx3.0-compat.patch
new file mode 100644
index 0000000..c5ed573
--- /dev/null
+++ b/debian/patches/04-wx3.0-compat.patch
@@ -0,0 +1,21 @@
+--- a/DSV/DSV.py
++++ b/DSV/DSV.py
+@@ -676,7 +676,7 @@ if wx is not None:
+ style = wx.TAB_TRAVERSAL, name = "ImportWizardPanel"):
+ wx.Panel.__init__(self, parent, id, pos, size, style, name)
+ self.SetAutoLayout(True)
+- mainSizer = wx.FlexGridSizer(3, 1)
++ mainSizer = wx.FlexGridSizer(4, 1)
+ self.SetSizer(mainSizer)
+ mainSizer.AddGrowableCol(0)
+
+@@ -1089,7 +1089,8 @@ if __name__ == '__main__':
+ else:
+ dlg.Destroy()
+
+- return True
++ # return True
++ sys.exit()
+
+ app = SampleApp()
+ app.MainLoop()
diff --git a/debian/patches/series b/debian/patches/series
index 4f81a67..eb38fd3 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
01-leave-env-alone.patch -p1
02-wx-namespace-transition.patch -p1
03-avoid-unicoditis.patch -p1
+04-wx3.0-compat.patch