summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGiuseppe Lavagetto <lavagetto@gmail.com>2013-11-23 23:59:27 +0100
committerGiuseppe Lavagetto <lavagetto@gmail.com>2013-12-02 19:34:25 +0100
commitae825e32d01cb26ee7da0410e1aa67e6a1a11b19 (patch)
treef7d596edba6231e9ecc899a108fdb305fe0d7ddb /setup.py
parent0e5789150352a6e841326edd51fb719d8f3cb1e9 (diff)
Complete rewrite of unit tests for requests using mox.
Unit tests needed to be rewriteen much more than integration tests. Mox is used instead of mock because it gives more strict control on call arguments for methods.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f1a652d..1677d77 100644
--- a/setup.py
+++ b/setup.py
@@ -10,7 +10,8 @@ version = '0.2.1'
install_requires = [
'urllib3==1.7',
- 'pyOpenSSL==0.13.1'
+ 'pyOpenSSL==0.13.1',
+ 'mox'
]