summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--NEWS.txt13
-rw-r--r--docs-source/conf.py2
-rw-r--r--setup.py2
3 files changed, 15 insertions, 2 deletions
diff --git a/NEWS.txt b/NEWS.txt
index cc3ae33..2158c21 100644
--- a/NEWS.txt
+++ b/NEWS.txt
@@ -1,6 +1,19 @@
News
====
+0.4.2
+-----
+*Release data: 8-Oct-2015*
+
+* Fixed lock documentation
+* Fixed lock sequences due to etcd 2.2 change
+* Better exception management during response processing
+* Fixed logging of cluster ID changes
+* Fixed subtree results
+* Do not check cluster ID if etcd responses don't contain the ID
+* Added a cause to EtcdConnectionFailed
+
+
0.4.1
-----
*Release date: 1-Aug-2015*
diff --git a/docs-source/conf.py b/docs-source/conf.py
index 8e4218d..996cb61 100644
--- a/docs-source/conf.py
+++ b/docs-source/conf.py
@@ -61,7 +61,7 @@ copyright = u'2013, Jose Plana'
# The short X.Y version.
version = '0.4'
# The full version, including alpha/beta/rc tags.
-release = '0.4.1'
+release = '0.4.2'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/setup.py b/setup.py
index f2401e8..011f798 100644
--- a/setup.py
+++ b/setup.py
@@ -6,7 +6,7 @@ README = open(os.path.join(here, 'README.rst')).read()
NEWS = open(os.path.join(here, 'NEWS.txt')).read()
-version = '0.4.1'
+version = '0.4.2'
install_requires = [
'urllib3>=1.7'