summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b496fe2..3d0d450 100644
--- a/setup.py
+++ b/setup.py
@@ -8,8 +8,15 @@ NEWS = open(os.path.join(here, 'NEWS.txt')).read()
version = '0.4.2'
+# Dnspython is two different packages depending on python version
+if sys.version_info.major == 2:
+ dns = 'dnspython'
+else:
+ dns = 'dnspython3'
+
install_requires = [
- 'urllib3>=1.7.1'
+ 'urllib3>=1.7.1',
+ dns
]
test_requires = [