summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera <hugo@barrera.io>2016-08-12 04:52:32 -0300
committerHugo Osvaldo Barrera <hugo@barrera.io>2016-08-12 04:56:27 -0300
commit2472f24b85205e97a04eca6f21c1497c192478bb (patch)
tree7370bf566c3feeeaf806f1ea8bd5b9237d018653 /setup.py
parent426db1e9fe3054bbb0c0ab6c7e3bbf37a21a0df5 (diff)
Use the new official python-xlib package
Upstream now supports both python2.7 and python3, so we can now always rely on python-xlib.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 3 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 7a746a5..c86889c 100644
--- a/setup.py
+++ b/setup.py
@@ -4,14 +4,8 @@ except ImportError:
from distutils.core import setup
import sys, re
-if sys.version > '3':
- install_requires = ['python3-xlib']
-else:
- # I can not specify Xlib as a dependency now as there is no
- # release for python2 on PyPi
- install_requires = []
- if sys.version_info < (2, 6):
- sys.exit("ewmh >= 0.1.3 requires python >= 2.6")
+if sys.version_info < (2, 6):
+ sys.exit("ewmh >= 0.1.3 requires python >= 2.6")
setup(name='ewmh',
version=re.findall("__version__ = '(.+)'", open('ewmh/__init__.py').read())[0],
@@ -21,6 +15,6 @@ setup(name='ewmh',
author_email="j.parkouss@gmail.com",
url='https://github.com/parkouss/pyewmh',
packages=['ewmh'],
- install_requires=install_requires,
+ install_requires=['python-xlib'],
license='LGPL',
)