summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2017-09-07 14:33:43 +0200
committerMarie Alexandre <alexandre.marie@synchrotron-soleil.fr>2019-07-08 11:31:53 +0200
commite8abe63e08598abb53c66a3b623d936e8fff1ba6 (patch)
tree1fd0a62dbfeac6a3891f5e36fe16cbcd64d1df45
parent9d1c321e8f66c85548fd1ad774ec5cce14cc2e2f (diff)
fix the install_requires depends
Gbp-Pq: Name 0002-fix-the-install_requires-depends.patch
-rw-r--r--setup.py10
1 files changed, 9 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index bc165cb..8b0dcb2 100644
--- a/setup.py
+++ b/setup.py
@@ -963,7 +963,15 @@ def get_project_configuration(dry_run):
# for most of the computation
"numpy%s" % numpy_requested_version,
# for the script launcher
- "setuptools"]
+ "setuptools",
+ # for debian
+ "h5py",
+ "lxml",
+ "matplotlib",
+ "pil",
+ "PyQt5",
+ "six"
+ ]
setup_requires = ["setuptools", "numpy"]